Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
17650 Discussions

Wrong driver installed

Ji
Beginner
354 Views

After revert wrong version driver and reinstall correct version, all UI is sluggish on windows 10. My PC is with intel i5 3330. By mistake, I installed 4th gen driver as win64_15.40.46.5144.exe. all UI’s takes too long time.

So I uninstall it and reinstall by win64_15.33.51.5146.exe. But the UI is slow as google   chrome browser takes about 1 minute to start. MS Edge takes over 2 minutes.

how can I fix this problem? Thank you so much,         Ji

0 Kudos
3 Replies
Maria_R_Intel
Moderator
327 Views

Hello Ji,


Thank you for posting on the Intel* Community.


Due to this product being discontinued, Intel Customer Service no longer supports inquiries for it, but perhaps fellow community members have the knowledge to jump in and help. You may also find the Discontinued Products website helpful to address your request, and also you can check the processor specifications here.


Thank you for understanding.


Best regards,

Maria R.

Intel Customer Support Technician


AlHill
Super User
325 Views

Get the exe of the driver you want.

Disconnect from the net.

In the device mangler, for the display adapter in question, delete the driver (using the checkbox to delete all software), and repeat until you get down to the Microsoft basic display adapter.  Multiple restarts may be needed.

Then, install the exe you previously downloaded.

Then, reconnect to the net.

 

Ji
Beginner
295 Views

Hello AlHill, the super user,

  Thank you so much for kindly suggestions and sorry for late reply.

  Unfortunately, it didn’t resolve my issue.

  So I tried Reset This PC and it’s working OK.

  Thank you so much again,      Ji

Reply