Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
17659 Discussions

the installing package is not supported by the processor

cmaxw1
Beginner
300 Views

hello, there is update for my graphic integreded card. i tired installing it it says the installing package is not supported by the processor

my computer is Lenovo v530 15ICM , intel core i3-8100 windows 10 pro 64x i don't know what the model of the card, i also tried installing older driver but same thing. my windows 10 version is 1511, i need the driver because i'm working on video editing software which require openGL, my software was working without this driver but i don't know why it says that my openGL is not supported through my GPU or CPU, any help would be appreciated

0 Kudos
1 Solution
AlHill
Super User
185 Views

You have UHD Graphics 630.

The drivers for your PROCESSOR can be found here:

https://ark.intel.com/content/www/us/en/ark/products/126688/intel-core-i3-8100-processor-6m-cache-3-...

Your OpenGL is 4.5.

 

However, they will likely not install on your lenovo due to customizations/modifications by lenovo. Use the lenovo drivers for your device.

 

Doc

 

View solution in original post

2 Replies
AlHill
Super User
186 Views

You have UHD Graphics 630.

The drivers for your PROCESSOR can be found here:

https://ark.intel.com/content/www/us/en/ark/products/126688/intel-core-i3-8100-processor-6m-cache-3-...

Your OpenGL is 4.5.

 

However, they will likely not install on your lenovo due to customizations/modifications by lenovo. Use the lenovo drivers for your device.

 

Doc

 

cmaxw1
Beginner
185 Views

thank you for taking the time to answer, my fix was, i did update windows to latest version it took half day till it finished updating, and everything worked, i even did not install the new driver, and in my OpenGL software it say all version of OpenGL are supported from 1.0. to 4.6 after the windows update, before i update it was saying i only have version 1.0, this my fix for anyone having the same issue, thank you

Reply