Intel® ARC™ Graphics
Get answers to your questions or issues when gaming on the world’s best discrete video cards with the latest news surrounding Intel® ARC™ Graphics
1724 Discussions

Borderlands 2 (Steam version) Directx9 API - low fps and stuttering in open areas with enemies/NPCs

vinilzord_learns
Beginner
268 Views

Hello Intel Techs, I've tried everything under the Sun to improve my in-game frame rate, and I'm very proud of what I was able to accomplish, but unfortunately it's still not enough to make the experience enjoyable.

I've tweaked the WillowEngine.ini file (where all graphics settings are placed) from the inside out, and I'm still getting only 40-50fps during combat gameplay, especially when there are multiple enemies or when I'm in an open wide area. For some reason, I get stable 120fps when navigating the in-game main menu, despite the graphics being rendered in the background the whole time. I found it odd. If I can maintain good fps in the main menu, why doesn't it happen during actual gameplay? Even when I'm standing idle at the town, staring at anywhere, I'm getting low fps. I suspect the issue lies within rendering NPCs/enemies or wide open areas. I understand this game is quite old, built on 32-bits architecture and running Directx9, and the game's devs didn't care about updating it, but my laptop still has a lot more horsepower than necessary to run it flawlessly, despite the lack of optimization for modern hardware and Windows 11.

Also, everything indicates that the DXVK d3d9.dll file to translate Directx9 to Vulkan is unusable now, because apparently the devs have already implemented it in the most recent drivers. When I tried to use it, I got even worse performance: MASSIVE stuttering (with out-of-whack frametime) and only 30fps. The game literally played like a slideshow. [b]Exactly 1 year ago, it ran just fine using the DXVK d3d9.dll file, no issues at all.[/b]

Specs:
Lenovo Yoga Slim 7 laptop - 16IAH7 model
Windows 11 OS
i7 12700H gen CPU
Intel Arc 370M GPU
32gb RAM DDR5

Game: Borderlands 2 - Steam version

*ALL DRIVERS ARE UPDATED

**Useful info: I've tested running the game as an administrator, disabling/enabling "full screen optimizations" within the Compatibility tab, running the game on Fullscreen Exclusive mode and Fullscreen Windowed mode. I'm not using the Ultra HD texture pack DLC, I have tweaked the [MemoryBudget] values and several other "resource hogs" that could potentially worsen in-game performance (they lie inside the WillowEngine.ini file). I thoroughly tested turning some settings on/off and I still got terrible fps in the aforementioned scenarios: combat gameplay AND standing idle at the town with multiple NPCs being rendered, however I can maintain stable 100+ fps inside buildings/closed areas with fewer NPCs.

I'll attach the latest SSU log and the WillowEngine.ini file so we can figure out together how to fix this. I understand that it's hard to improve the performance of older games and that you guys are putting more attention and time into Directx 11/12 games, that's fair, but the performance issues that I'm having are not reasonable, in my humble opinion.

Thank you in advance! :))

0 Kudos
2 Replies
vinilzord_learns
Beginner
209 Views

Okay, quick update: I did a clean install with DDU and installed the newest drivers.

The game now is way more stable with DXVK compared to native D3D9. I ran a benchmark for like 2 mins and the 1% and 0.1% lows weren't too bad. I am averaging about stable 72 fps, even when transitioning to new open wide areas. It's playable, but my average fps is still somewhat low given that this game is 10 years old.

I can play it now without too much stuttering, but the average fps is still suboptimal. Btw I messed a bit with Process Lasso, but it didn't make any difference. One thing that helps immensely is turning on Processor Performance Boost in the Power Plan options, but it nearly doubled the temperature of the CPU so I decided to keep it off (average CPU temperature with CPU Boost is around 92C, and turned off it's 50-55C).

I kindly ask for some help so I can have like stable 90fps, that will make the gameplay much smoother. Thanks!

0 Kudos
AllisWell_42
Novice
100 Views

hello there @vinilzord_learns 

 

Improving frame rates in older games can be a bit tricky  let's explore a few additional steps that might help improve your frame rate in Borderlands 2.

  1. Borderlands 2 FPS Fix (DXVK):
    • You’ve already tried DXVK, but let’s revisit it. Make sure your GPU supports Vulkan (which it should). If you haven’t already, download DXVK from here.
      • Extract the folder using Winrar or 7-Zip.
      • Grab the d3d9.dll and dxgi.dll from the x32 folder and copy them to the game’s executable location (usually Borderlands2/Binaries/Win32).
      • This should switch the renderer to Vulkan, potentially improving performance. You mentioned a boost of 40fps, but results may vary based on your specs.
      • Set PhysX to Low if it isn’t already. It can be disabled, but that might cause issues with particles.
  2. Windows Settings and Graphics Options:
      • Add Borderlands 2 in Windows Settings > Graphics settings and set the performance preference to High Performance.
      • In your Nvidia or AMD control panel, consider disabling G-sync or FreeSync, set the monitor technology to fixed refresh rate, and match the max FPS to your monitor’s refresh rate.
  3. WillowEngine.ini Tweaks:
      • You’ve already tweaked the [MemoryBudget] values, which is great. Keep experimenting with other settings in the WillowEngine.ini file.
      • Consider disabling full-screen optimizations (you’ve tried this already).
  4. Monitor Refresh Rate and Vsync:
      • Ensure your monitor’s refresh rate is set correctly in Windows display settings.
      • Disable Vsync in the game settings to avoid frame rate caps.
  5. Processor Performance Boost:
    • While enabling Processor Performance Boost can improve performance, monitor your CPU temperature closely. If it’s causing excessive heat, it might not be sustainable

 

Remember that Borderlands 2 is an older game, and achieving stable high frame rates can be challenging due to its architecture. However, with the right tweaks, you should be able to get closer to your desired 90fps

 

hope it helps...

 

williams

0 Kudos
Reply