Intel® ARC™ Graphics
Get answers to your questions or issues when gaming on the world’s best discrete video cards with the latest news surrounding Intel® ARC™ Graphics
1442 Discussions

Intel ARC has difficulties to work on Alienware Ryzen motherboard

Mascready
Novice
1,789 Views

Hello. I just received my Arc A770.

 

Beautiful design, really impressed by the work of art so far.

 

To test it out, I decided to install it on my actual rig : a Alienware Aurora R10 Ryzen Ed. (yes, I know...)

 

The Dell motherboard is a funny thing. The graphic connector (PCIe 4.0 x16) doesn't play well with this new card : no display output. The chipset is a B450A, an OEM B450 that have just a bit of PCIe 4.0 connectivity (graphic and NVMe SSD)

 

I logged via a remote desktop connection and "oh surprise" no device to be found. Impossible to install Intel drivers obviously.

 

So I plugged it in the second PCIe slot (3.0 x4) and... It worked ! It isn't the solution I was hoping for but good enough for now.

 

So now benchmarking it with 3dmark (sorry Intel) and I'll see if the PCIe bandwidth have a big impact on your card. My config : Ryzen 3600x with 32g of DDR4-3200 and nvme PCIe 4.0 So far, my machine managed to pull a decent score of 8987 in Time Spy (Worst result of the entire database).

Capture d’écran 2022-10-27 213844.png

My CPU seem to be a bottleneck : in this test, my CPU score decreased by 2%.

Capture d’écran 2022-10-27 214314.png

I can't wait to try it out in my future rig. Hoping that a good motherboard with a Ryzen 5800x (with SAM enabled) will solve the issue.

 

Until then, I would be very interested in suggestions on how to remedy this problem. Thanks for your time.

12 Replies
knarf
Novice
1,769 Views

Patch your bios

I had issues on AMD MSI B550 where SVM (virtualisation) was stopping it boot.

Mascready
Novice
1,745 Views

I'm using the last BIOS version but as I understand, my motherboard hardware version will not receive AGESA updates in the future so no Rebar / SAM.

 

I will try to disable virtualisation and I'll update you.

 

Thanks for the tip.

 

Edit : Didn't solve my problem. I'll reuse my GTX 1660 Ti for the moment and I'll wait for my new parts. Thank you again for your help.

Danrdz10103
New Contributor I
1,685 Views

Same thing here. I turned off all visualization and no luck! I Did not have an specific setting of SVM, so I just selected virtualization "disable" but it did not do anything. thanks for the suggestion.

0 Kudos
Danrdz10103
New Contributor I
1,685 Views

wow I am facing the same issue. any chance you are using a Alienware Aurora Ryzen?

Mine 3800X wont show any video and I was begging to think it was the video cable so I just ordered a new one.

So is it not me? there is no hope to boot with the A770 on a Alienware Ryzen? 

Mascready
Novice
1,583 Views

Hey. Yes, I used a Aurora R10 Ryzen ed.

 

Found no solution. I think every piece of hardware is digitally signed. RAM is... Dell / Alienware is a trash company. And as said Intel during a Dell judgement "Dell is the best friend money can buy"

Danrdz10103
New Contributor I
1,576 Views

Thanks for the reply. I lost hope and I bought a NUC 12 extreme to use my A770. So far going great.

now I need to find someone who wants to buy this Ryzen 3800X Aurora R10.

0 Kudos
Mascready
Novice
1,545 Views

Totally in the same case ...... 7ngxra1kawez1

0 Kudos
Carlos_L_Intel
Moderator
1,543 Views

Hi @Mascready


Thank you for posting on the Intel® communities and thank you for the discussion. If you like us to take a closer look at this, can you please share the following information:




Best regards,  

Carlos L.  

Intel Customer Support Technician


0 Kudos
Mascready
Novice
1,482 Views

Hello.

 

I've changed my PC since then. If it can help other users, I can send you my informations.

 

Thank you

0 Kudos
Carlos_L_Intel
Moderator
1,505 Views

Hello @Mascready


Were you able to check the previous post?  

Let us know if you still need assistance.  


Best regards,  

Carlos L.  

Intel Customer Support Technician


0 Kudos
Carlos_L_Intel
Moderator
1,485 Views

Hello @Danrdz10103


We have not heard back from you, so we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored. 


Best regards,  

Carlos L. 

Intel Customer Support Technician


Danrdz10103
New Contributor I
1,478 Views

Thanks. sorry it was a busy week. I will digest theinformation and post another question if needed. thanks.

0 Kudos
Reply