Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JMell10
Beginner
860 Views

AMT unreachable when powering off...

Hi, sorry for posting here after I have posted on Intel-vPro forum, I barely could get an answer over there, so I hope I have more luck here since this forum appears to be more active and the users more "pro-active".

I have a GA-Q270M-D3H with ME 11.8.65.3590 (latest one for Q270 Chipset). AMT WebUI, KVM and everything else is working when the computer is turned on.

As soon as I turn it off AMT goes away. No response on ping and no WebUI either. This is a linux system so I haven't used any Intel GUI tools to configure so everything was configured by using MEBx menu.

The power control is configured for: <Desktop: ON in S0, ME Wake in S3, S4-5>, idle timeout: 65535. IP is static and different from the OS. The hostname is dedicated to AMT. I can ping the hostname so DNS resolution is working, but If I turn off the computer (AC connected) everything goes away. I can see some activity on one NIC led indicating a 10Mbps link and ready for Wake on Lan which by the way is working without any issues. 

Question: Is there any way to keep AMT "ON" permanently?

Any ideas? Suggestions? I'm all ears :).

Thanks in advance.

0 Kudos
6 Replies
Joseph_O_Intel1
Employee
860 Views

Hey Joao,

A couple of questions

  1. What happens when you run the following command "ping <AMT IP ADDRESS> -t"?
    1. Please start the ping and then shut down the system
  2. With the system on, from a remote system, connect to WebUI and log in http://AMTipaddress:16992
    1. Some settings can be configured here
  3. Change your idle timeout to 0

 

JMell10
Beginner
860 Views

Thanks Joseph for your response.

1. I get intermittent responses between "request timed outs", sometimes 10 responses in a row and then fails again (from the moment I turn the system off the WebUI becomes unreachable, one time or another I can get to the login form but it's impossibly slow and I never could pass the login form. Important to say that the NIC at this point is operating at 10Mbps that is, one led blinking only. 

2. I already checked the WebUI and I couldn't find anything that could help regarding the issue.

3. Unfortunately MEBx doesn't  accept a lower value than 1 for the timeout :(

The Onboard Intel NIC is a I219-LM  with the 0.0.15 UEFI driver, it seems that the NIC goes to power down leaving AMT talking to nobody,.

Joseph_O_Intel1
Employee
860 Views

In general, if we are connecting to the wired NIC, I would expect t a ping drop of maybe two and then resume. The fact that you are not able to reach the MEBxafter shut down is not correct. 

Keep in mind having the MEBx not being consistent with the OS is not a standard practice. As I am unsure of all the customization you may have done, lets set the MEBx in a basic configuration by doing the following:

  1. Log into the MEBX
  2. Perform a full un-provision from the MEBx
  3. reboot the system
  4. Enter the MEBx and enable AMT (this is a single option)
  5. reboot
  6. ping OS IP as requested earlier
  7. Reboot your system.
  8. Ping should stay in place, might drop a few packets during the hand over from OS to AMT, however, when the handoff occurs the TTL will change.
  9. Whats your results?

Feel free to private message me your contact info if this doesn't work or is unclear

 

 

JMell10
Beginner
860 Views

Hi Joseph.

I did exactly what you suggested step by step. With AMT and the OS sharing the IP (DHCP)  the TTL actually changes when the hand over occurs but just for a moment and then AMT goes away for good which is different with static IP configuration (different from the OS) when AMT occasionally responds.

There's a screenshot attached.

Thanks.

 

 

 

JMell10
Beginner
860 Views

I'm back and definitely I think that is a NIC firmware problem.

I have a Lenovo P50 where AMT works like charm with the system ON or OFF.

I noticed one thing: When I turn off the system the NIC goes down to a 10Mbps link (which is normal for a system with wake on lan enabled). Both systems does that, but only the Lenovo keeps responding to pings. So I configured the Q270 NIC on Bios to a fixed 100Mbps link and immediately I lost the communication with the network, even with the switch configured for "Auto negotiation". It doesn't matter 10 or 100 Mbps the behavior is the same: Barely responding to pings exactly as my testing before. I installed Windows and I got the same result.

To avoid the switch getting in the way I tested with a direct connection with another system and no joy. Only at 1Gbps I get a reliable link and communication with the network.

Conclusion: The onboard NIC isn't working below 1Gbps and I'm out of luck since the 10Mbps is the default when the system is turned off. I had problems with Network cards not going up but never going down, so I think it's a firmware issue.

Does it make sense?

Thanks.

 

 

 

 

 

Joseph_O_Intel1
Employee
860 Views

Sorry for the delay, I was doing a bit of research and I agree that is is a firmware issue. As such I would do a BIOS and ME firmware update and see if it gets resolved in that fashion.

 

Joe

Reply