Community
cancel
Showing results for 
Search instead for 
Did you mean: 
johanvandberg
Beginner
198 Views

Could not establish trust relationship for the SSL/TLS secure channel

4 Months ago (October 2008) we configured a test network for testing our AMT systems, and this network has not been used since December 2008. This week we started some testing again (26 January 2009) and all of a sudden AMT SCS Console is unable to access the SCS server. We get an error from AmtConsole.exe "Could not establish trust relationship for the SSL/TLS secure channel". AmtConsole.exe version is "5.0.2.4", and the hole environment worked just fine a month ago. Please advise. We use SCS = "Intel_AMT_SCS_Release_5.0.2.4_Hotfix.zip"
0 Kudos
4 Replies
jacace
Black Belt
198 Views


Hello Johan,


I experienced things likethese some time ago.
My first question will be: Is onlythe serverSSL/TLS secured?
If it's so, I think that client machine does not trust in server's security certificate.

So, please check if the server's securitycertificate isin theclient's trusted root certificate store. if it is not, please add it and try again.
Gael_H_Intel
Moderator
198 Views


Hello Johan,


I experienced things likethese some time ago.
My first question will be: Is onlythe serverSSL/TLS secured?
If it's so, I think that client machine does not trust in server's security certificate.

So, please check if the server's securitycertificate isin theclient's trusted root certificate store. if it is not, please add it and try again.

Johan - did Javier's advice help? Javier also recently wrote a nice blog regarding his SSL/TLS issues. You also may want to check all your times on your system/AMT/Certs - make sure your certs didn't expire, for example.

Let us know how it's going!
Thanks!
johanvandberg
Beginner
198 Views

Quoting - johanvandberg
4 Months ago (October 2008) we configured a test network for testing our AMT systems, and this network has not been used since December 2008. This week we started some testing again (26 January 2009) and all of a sudden AMT SCS Console is unable to access the SCS server. We get an error from AmtConsole.exe "Could not establish trust relationship for the SSL/TLS secure channel". AmtConsole.exe version is "5.0.2.4", and the hole environment worked just fine a month ago. Please advise. We use SCS = "Intel_AMT_SCS_Release_5.0.2.4_Hotfix.zip"
Thank you all for helping - the problem was quite obvious in the end. The server certifficate was quite old and expired on 20 December 2008. I followed the standard IIS certifficate renewal process [from Computer Management - IIS configurations] to request a new certifficate from the CA. Once the new certifficate was installed on both IIS and the client station everything returned to normal :-). Best regards. Johan.
Gael_H_Intel
Moderator
198 Views

Quoting - johanvandberg
Thank you all for helping - the problem was quite obvious in the end. The server certifficate was quite old and expired on 20 December 2008. I followed the standard IIS certifficate renewal process [from Computer Management - IIS configurations] to request a new certifficate from the CA. Once the new certifficate was installed on both IIS and the client station everything returned to normal :-). Best regards. Johan.

Wonderful!! I'm glad everything is back to normal for you. (I'm still trying to figure out what is normal. LOL)
Reply