Intel® Business Client Software Development
Support for Intel® vPro™ software development and the technologies associated with Intel vPro platforms.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.

WsMan Asset Vs. EOI Asset

jacace
Black Belt
308 Views

Hello everybody,

I have been looking into the differencies between the EOI and the WsMan asset.
I have seen that the following functions does not get all the information:
arrTmp=client.Enumerate(typeof(CIM_ProcessorType));
arrTmp = client.Enumerate(typeof(CIM_PhysicalMemoryType));
arrTmp = client.Enumerate(typeof(CIM_MediaAccessDeviceType));
arrTmp=client.Enumerate(typeof(AMT_PCIDeviceType));

The thing is that the above MOF classes(CIM_XXX, AMT_XXX)are the ones used to deserialize the WsMan commands, so after Enumerating them and call the respective Intel AMT stack object constructor I can see not all the information is loaded; I mean, if I compare WsManconstructed objectagain the corresponding EOI object (GetAssetOfType(AmtHardwareModule.XXX)) not all the information is present.

So, wha's wrong?

Thanks a lot,

Javier Andrs Cceres Alvis

0 Kudos
1 Solution
Randal_T_Intel
Employee
308 Views
This is a known bug in the WsMan implementation of the Asset interface. You're not doing anything wrong

View solution in original post

8 Replies
jacace
Black Belt
308 Views
Any suggestion?
Thanks a lot,
Javier Andrs Cceres Alvis

Lance_A_Intel
Employee
308 Views


Hi Javier, we are seeking assistance from our WS-Man expert on this one. Hope to get back to you soon.

jacace
Black Belt
308 Views
Thanks a lot Lance!
;-)

Randal_T_Intel
Employee
309 Views
This is a known bug in the WsMan implementation of the Asset interface. You're not doing anything wrong

jacace
Black Belt
308 Views
This is a known bug in the WsMan implementation of the Asset interface. You're not doing anything wrong


Thanks a lot Randal,

Javier Andrs Cceres Alvis

jacace
Black Belt
308 Views
This is a known bug in the WsMan implementation of the Asset interface. You're not doing anything wrong

Hello Randal,

I have a question: I understand this issue is about theWsMan implementation on machine (I mean, I supose there is a bug on code running at the amt machine side); my AMT version is 3.2.1, What do you knowabout AMT 4, 5 versions?

I have more feedback: this also affects Redirection cause power state is found by WsMan as "S2_SLEEPING_WITHOUT_CONTEXT" and by EOI is correctly read as "SO_POWERED". (see this thread: http://software.intel.com/en-us/forums/showthread.php?t=61463)

Thanks a lot,

Javier Andrs Cceres Alvis

Randal_T_Intel
Employee
308 Views
Thanks for the feedback. The WsMan asset issue appears to be limited to 3.x firmware.The SDK asset sample should work on AT4/5 hardware

jacace
Black Belt
308 Views
Thanks for the feedback. The WsMan asset issue appears to be limited to 3.x firmware.The SDK asset sample should work on AT4/5 hardware

Thanks Randal

=)

Reply