Community
cancel
Showing results for 
Search instead for 
Did you mean: 
duncanchou
New Contributor I
263 Views

IntelMediaSDK2017forEmbeddedLinux-PV-MR4-B-02 Can not work on E3950

Hello Sir,

We get below message while doing  samaple_decode example of  IntelMediaSDK2017forEmbeddedLinux ,   but our VA-API version 1.7.0 from vainfo, 

Could you help us fix this issue, may some steps we mistakes?

The test log is test_20200908.txt

Thanks

Michael Wu

libva info: VA-API version 0.40.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /usr/lib64/dri/iHD_drv_video.so
libva error: /usr/lib64/dri/iHD_drv_video.so has no function __vaDriverInit_0_32
libva info: va_openDriver() returns -1

[ERROR], sts=MFX_ERR_MEMORY_ALLOC(-4), CreateAllocator, CreateHWDevice failed at /opt/intel/mediasdk/samples/sample_decode/src/pipeline_decode.cpp:1277

[ERROR], sts=MFX_ERR_MEMORY_ALLOC(-4), Init, CreateAllocator failed at /opt/intel/mediasdk/samples/sample_decode/src/pipeline_decode.cpp:438

[ERROR], sts=MFX_ERR_MEMORY_ALLOC(-4), main, Pipeline.Init failed at /opt/intel/mediasdk/samples/sample_decode/src/sample_decode.cpp:720

 

-sh-4.4# vainfo
error: can't connect to X server!
libva info: VA-API version 1.7.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /usr/lib64/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.7 (libva 2.7.0)
vainfo: Driver version: Intel iHD driver for Intel(R) Gen Graphics - 20.1.1 (54492c0)
vainfo: Supported profile and entrypoints
VAProfileNone : VAEntrypointVideoProc
VAProfileNone : VAEntrypointStats
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointVLD
VAProfileH264Main : VAEntrypointVLD
VAProfileH264Main : VAEntrypointEncSlice
VAProfileH264Main : VAEntrypointFEI
VAProfileH264Main : VAEntrypointEncSliceLP
VAProfileH264High : VAEntrypointVLD
VAProfileH264High : VAEntrypointEncSlice
VAProfileH264High : VAEntrypointFEI
VAProfileH264High : VAEntrypointEncSliceLP
VAProfileVC1Simple : VAEntrypointVLD
VAProfileVC1Main : VAEntrypointVLD
VAProfileVC1Advanced : VAEntrypointVLD
VAProfileJPEGBaseline : VAEntrypointVLD
VAProfileJPEGBaseline : VAEntrypointEncPicture
VAProfileH264ConstrainedBaseline: VAEntrypointVLD
VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
VAProfileH264ConstrainedBaseline: VAEntrypointFEI
VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP
VAProfileVP8Version0_3 : VAEntrypointVLD
VAProfileHEVCMain : VAEntrypointVLD
VAProfileHEVCMain : VAEntrypointEncSlice
VAProfileHEVCMain : VAEntrypointFEI
VAProfileHEVCMain10 : VAEntrypointVLD
VAProfileVP9Profile0 : VAEntrypointVLD

 

0 Kudos
1 Reply
duncanchou
New Contributor I
203 Views

Hello Sir

We do the sample code of  "IntelMediaSDK2017forEmbeddedLinux-PV-MR4-B-02", always get below error message,  and  get version information  is 0.40.0, 

but our VA-API version is    VA-API version 1.9.0, not  0.40.0.

Anything we misunderstanding?

Does the  "IntelMediaSDK2017forEmbeddedLinux-PV-MR4-B-02"  be supported on VA-API version 1.9.0 ?

-------------------------------- 

-sh-4.4#pwd

/opt/intel/mediasdk/samples/__cmake/intel64.make.release/__bin/release

-sh-4.4#./sample_decode h264 -hw -vaapi -i /mnt/nfsshare/camera_124_640x_480.h264 -o test.rgb

libva info: VA-API version 0.40.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /usr/lib64/dri/iHD_drv_video.so
libva error: /usr/lib64/dri/iHD_drv_video.so has no function __vaDriverInit_0_32
libva info: va_openDriver() returns -1
libva info: VA-API version 0.40.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /usr/lib64/dri/iHD_drv_video.so
libva error: /usr/lib64/dri/iHD_drv_video.so has no function __vaDriverInit_0_32
libva info: va_openDriver() returns -1

.....

-sh-4.4#vainfo

libva info: VA-API version 1.9.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /usr/lib64/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.9 (libva 2.7.0)
vainfo: Driver version: Intel iHD driver for Intel(R) Gen Graphics - 20.1.1 (54492c0)
vainfo: Supported profile and entrypoints
VAProfileNone : VAEntrypointVideoProc
VAProfileNone : VAEntrypointStats
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointVLD
VAProfileH264Main : VAEntrypointVLD

 

Michael 

Reply