Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
63 Views

MCU REPORTS CONNECTION FAILED FOR STREAM

Jump to solution

Dear Team,

I installed MCU server on AWS and opened all udp incoming and outgoing and allowed all traffic and configured my server public ip in this places

1. in webrtc_agent/agent.toml: cluster->ip_address set to internal network ip address, webrtc->ip_address set to public network ip

2. in video_agent/agent.toml cluster->ip_address set to internal ip address

3. in audio_agent/agent.toml cluster->ip_address set to internal ip address

4.  in access_agent/agent.toml cluster->ip_address set to internal ip address

5. in portal/portal.toml, portal->ip_address set to public network ip

still i am  getting stream getting error as shown in attachement  . In Chrome only getting self view not getting subscribe stream, In firefox not even getting self  video and subscriber video

Ports Opened are : 

tcp 0 0 0.0.0.0:42212 0.0.0.0:* LISTEN 19957/beam.smp

 

tcp 0 0 127.0.0.1:27017 0.0.0.0:* LISTEN 19086/mongod

 

tcp 0 0 127.0.0.1:28017 0.0.0.0:* LISTEN 19086/mongod

 

tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1012/sshd

 

tcp6 0 0 :::5672 :::* LISTEN 19957/beam.smp

 

tcp6 0 0 :::8080 :::* LISTEN 15778/node

 

tcp6 0 0 :::8081 :::* LISTEN 15778/node

 

tcp6 0 0 :::4369 :::* LISTEN 19919/epmd

 

tcp6 0 0 :::22 :::* LISTEN 1012/sshd

 

tcp6 0 0 :::3000 :::* LISTEN 15660/node

 

tcp6 0 0 :::3001 :::* LISTEN 16298/node

 

tcp6 0 0 :::3004 :::* LISTEN 16298/node

 

udp 0 0 0.0.0.0:59785 0.0.0.0:* 16015/woogeen_sip

 

udp 0 0 0.0.0.0:48525 0.0.0.0:* 16009/woogeen_sip

 

udp 0 0 0.0.0.0:68 0.0.0.0:* 640/dhclient

 

udp 0 0 0.0.0.0:22661 0.0.0.0:* 640/dhclient

 

udp6 0 0 :::10366 :::* 640/dhclient

 

 

 

 

 

So

 

Tags (2)
0 Kudos

Accepted Solutions
Highlighted
63 Views

Kiranraj, thanks for the reply. Yes, we updated webrtc external network configuration setting, please specify network interface name and external ip.

BTW, please make sure ports for webrtc connection and internal streaming are open:

1. For internal streaming port setting (TCP), please set maxport and minport to opened port range in following files:

section internal in video_agent/agent.toml

section internal in audio_agent/agent.toml

section internal in webrtc_agent/agent.toml

for recording, rtsp and rtmp streamin, pelase modify port range in recording_agent/agent.toml or avstream_agent/agent.toml

2. For external streaming port setting (UDP), please set port range in section webrtc in webrtc_agent/agent.toml

 

 

View solution in original post

0 Kudos
4 Replies
Highlighted
Beginner
63 Views

Dear Anil

please look the below screenshot the webrtcagent.toml file does not updated the public-ip thats the reason video not getting out

Please check ip_address setting in MCU, for NAT network environment, you should follow configurations below to allow external access to MCU:

1. in webrtc_agent/agent.toml: cluster->ip_address set to internal network ip address, webrtc->ip_address set to public network ip

2. in video_agent/agent.toml cluster->ip_address set to internal ip address

3. in audio_agent/agent.toml cluster->ip_address set to internal ip address

4.  in access_agent/agent.toml cluster->ip_address set to internal ip address

5. in portal/portal.toml, portal->ip_address set to public network ip

below shows how to assign public ip in mcu3.4.1v webrtcagent.toml 

[{name = "eth0", replaced_ip_address = "1.2.3.4"}]

if rabbitmq is running in different machine in all toml file update the internal ip of rabbitmq server and add the below configuration in rabbitmq server to accept conections from other maches
/etc/rabbitmq/rabbitmq.config
[{rabbit, [{loopback_users, []}]}].

i think this will help you 

 

0 Kudos
Highlighted
64 Views

Kiranraj, thanks for the reply. Yes, we updated webrtc external network configuration setting, please specify network interface name and external ip.

BTW, please make sure ports for webrtc connection and internal streaming are open:

1. For internal streaming port setting (TCP), please set maxport and minport to opened port range in following files:

section internal in video_agent/agent.toml

section internal in audio_agent/agent.toml

section internal in webrtc_agent/agent.toml

for recording, rtsp and rtmp streamin, pelase modify port range in recording_agent/agent.toml or avstream_agent/agent.toml

2. For external streaming port setting (UDP), please set port range in section webrtc in webrtc_agent/agent.toml

 

 

View solution in original post

0 Kudos
Highlighted
Beginner
63 Views

3.5.2版本中

设置portal/portal.toml  ip_address为映射的外网ip   port改为映射的端口

webrtc-agent/agent-toml中webrtc 

network_interfaces = [{name="eth0",replaced_ip_address=映射的外网ip"}]   这里的name为mcu中的网卡名称,还是外网的网卡名称

开启服务后,客户端请求portal模块中的ip+端口,请求websocket时无任何响应

https://外网地址:映射的端口/socket.io/?EIO=3&transport=polling&t=MBMuZxE

设置minport/maxport  若无上面的外网设置,仅设置端口,无法显示混合流画面 日志没有报错

nuve中的port是否需要映射到外网?

期待新版本的发布

0 Kudos
Highlighted
Beginner
63 Views

can you tell me your external network configuration setting?

0 Kudos