Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
1136 Discussions

MongoDB as seperate server - ERROR: Main - portal getting token failed

Chandramouli_P
Beginner
394 Views

Hello,

We are able to deploy and run MCU sample application successfully in the cloud. Now, I installed MongoDB in a different server and assigned the local hostname of MongodDB server in .toml files of Nuve, Portal, Conference-agent, Sip-portal folders. After initializing, when I execute "sudo bin/start-all.sh", It is connecting to MongoDB server and created the database also. But, I am getting the "Main - Failed to get token key. err: null" error. Please find the below log:

AmqpClient - Connecting to rabbitMQ server OK, hostPort: { host: 'localhost', port: 5672 }
INFO: Main - portal initializing as rpc client ok
INFO: Main - portal join cluster ok, with rpcID: portal-63f00094b53e59d6023b@13.58.34.29
INFO: ClusterWorker - Join cluster woogeen-cluster OK.
INFO: Main - portal initializing as rpc server ok
INFO: Main - portal-63f00094b53e59d6023b@13.58.34.29 as monitor ready
INFO: Main - Failed to get token key. err: null
ERROR: Main - portal getting token failed.

INFO: LoadCollector - To stop load collector.

Any help would be appreciated.

Thank you.

Best Regards,
Chandramouli.

0 Kudos
1 Solution
Qiujiao_W_Intel
Employee
394 Views

How did you initialize your nuve database? If you just run ./bin/init.sh it still use the default localhost as mongo service, please run ./nuve/init.sh --dburl xxxx to initialize nuve database.

View solution in original post

8 Replies
Chandramouli_P
Beginner
394 Views

Hello,

Any help would be appreciated.

Thank you.

Best Regards,
Chandramouli.

Chandramouli_P
Beginner
394 Views

Hello,

Any help would be appreciated.

Thank you.

Best Regards,
Chandramouli.

Chandramouli_P
Beginner
394 Views

Hello,

Any help would be appreciated.

Thank you.

Best Regards,
Chandramouli.

Qiujiao_W_Intel
Employee
395 Views

How did you initialize your nuve database? If you just run ./bin/init.sh it still use the default localhost as mongo service, please run ./nuve/init.sh --dburl xxxx to initialize nuve database.

View solution in original post

Chandramouli_P
Beginner
394 Views

Hello Qiujiao,

As you suggested, after passing the dburl in command line, it is throwing some error. So, I had given the DB URL in nuve/init.sh file and comment the MongoDB related lines bin/init-all.sh file. Now, it is working fine.

Thank you.

Best Regards,
Chandramouli.

Naresh_R_1
New Contributor I
394 Views

Hi,

When i am connecting as per above suggested i am getting below error for nuve

2019-02-26 13:08:59.901  - WARN: Nuve - { Error: WWW-Authenticate: MAuth realm="http://marte3.dit.upm.es"

  name: 'Error',

  status: 401,

  code: 1101,

  data: 

   { error: 

      { code: 1101,

        message: 'WWW-Authenticate: MAuth realm="http://marte3.dit.upm.es"' } } }

 

Please Suggest

 

Thanks

Naresh

Naresh_R_1
New Contributor I
394 Views

Dear Team,

I am facing similar issue when i am hosting mongodb as a separate server. i am not able connect as per the above said configuration.

we are using mongodb 3.4 version and MCU version 4.1.1.

we are able to create nuvedb on mongodb server but conference is not happening getting different errors everytime and services getting stopped.

can any one suggest with configuration.

 

Thanks

Naresh

Qiujiao_W_Intel
Employee
394 Views

Hi, Naresh, please check your bindip settings in mongodb. if it's 127.0.0.1, it can only be accessible from the same machine.

Reply