Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
92 Views

"Error: node not found" when running bin/init.sh

Hello, I am trying to install the v2.8 MCU server on ubuntu 14.04 inside of virtualbox.

I got up to the point of bin/init.sh --deps and things were going okay until this:

 

rabbitmq-server is already the newest version.
mongodb is already the newest version.
The following packages were automatically installed and are no longer required:
  ax25-node libax25 openbsd-inetd
Use 'apt-get autoremove' to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 46 not to upgrade.
Initializing mongodb...
MongoDB already running
Initializing default configuration...
Error: node not found. Please install node v0.10 first.
sed: can't read /home/s/Downloads/Release-v2.8/etc/woogeen_config.js: No such file or directory
s@ubuntu:~$ nodejs --version
v0.10.25
s@ubuntu:~$ 

As you can see, when i do 'nodejs --version' it states I have version v0.10.25 ... So why does bin/init.sh give me a "Please install node v0.10" error?

How can this be? What do I do? I am pretty sure I was following all the instructions right.

Tags (2)
0 Kudos
8 Replies
Highlighted
92 Views

Hi,

Could you tell me the node.js path on your system?

0 Kudos
Highlighted
New Contributor I
92 Views

Is this what you mean?

 

s@ubuntu:~$ which nodejs
/usr/bin/nodejs
s@ubuntu:~$ 

 

0 Kudos
Highlighted
New Contributor I
92 Views

I have been able to fix the problem by installing nodejs-legacy with

sudo apt-get install nodejs-legacy

 

0 Kudos
Highlighted
92 Views

Sound good. One more thing is that currently we recommend node version with 0.10.38 or later versions.

Thanks!

0 Kudos
Highlighted
Beginner
92 Views

CHUNBO H. (Intel) wrote:

Sound good. One more thing is that currently we recommend node version with 0.10.38 or later versions.

Thanks!

CS_WebRTC_Conference_Server_MCU.v3.0.1,Need Node.js version with 4 or later versions

output:

# ./init.sh
Initializing mongodb...
MongoDB already running
Initializing default configuration...
node version not match. Please use node v4

0 Kudos
Highlighted
92 Views

Yes, Node v4 and above is required for our 3.0 release.

Please refer to the server user guide for more details.

0 Kudos
Highlighted
New Contributor I
92 Views

Where is the conference server user guide located? I cannot find it.

I thought it might be here https://software.intel.com/en-us/webrtc-sdk-support

but it isn't.

I thought it might be within the Intel_CS_WebRTC.v3.0_Update2.zip

but it isn't.

Where is it!?

Also your statement about requiring "Node v4 and above" seems incorrect as I tried with node v5 and it failed but v4 worked fine.

edit: By luck I have found the user guide here: http://registrationcenter-download.intel.com/akdlm/irc_nas/8641/Intel_CS_WebRTC_User_Document.v3.0_Update2.zip

I really think you have to make this more obvious where to download though, I never found the link until I decided to play with the original download URL. What pages currently provide that link?

0 Kudos
Highlighted
92 Views

Hi Stephen,

Sorry for the inconvenience. We're now working on putting all of our documentation online, so that you do not have to download them.anymore.

Regarding the specific question, it is in the section of "CS_WebRTC_Server_User_Guide.v3.0/md_servermd__server.html#Conferencesection2_3_1".

Thanks!

0 Kudos