Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646

setup conference server in azure problem

Chao-Yu_C_
Beginner
125 Views

Environment : Azure VM : Ubuntu 14.04

change etc/woogeen_config.js
config.erizoController.hostname = 'webme.cloudapp.net'; //default value: ''

And set endpoint

port8095 TCP 8095 8095 -
port8080 TCP 8080 8080 -
port54578 TCP 54578 54578 -
port33430 TCP 33430 33430 -
port3001 TCP 3001 3001 -
port3000 TCP 3000 3000 -

 

when I open http://webme.cloudapp.net:3001/

I get errors like this
ERROR: 562f1782b22187c2340985a9 subscribe failed: peer connection failed
woogeen.sdk.js:8 ERROR: publish failed: peer connection failed

Is there some ports that I missed or config I should add?

 

0 Kudos
6 Replies
Chunbo_H_Intel1
Employee
125 Views

Hi Chaoyu,

Do you mean that you setup a port white list in your Azure VM? If so, I think the ports consumed by RTP would be a lot during the conference continuous usage.

Chao-Yu_C_
Beginner
125 Views

I found the problem is my router block the port.

thank you for your help.

 

Chunbo_H_Intel1
Employee
125 Views

Sound good! Let me know if you have further issues.

Chao-Yu_C_
Beginner
125 Views

I used another computer in another LAN. I found it's ok.
So I login my router admin page and found there is an access rule for router.

I also found a problem in my gateway settings.

 

 


 

 

 

Chunbo_H_Intel1
Employee
125 Views

This kind of further sharing is warmly welcome here! Thanks!

Chunbo_H_Intel1
Employee
125 Views

Cool. That's really what we want our forum to be.

Reply