Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1204 Discussions

FPGA Stratix 10 libsycl.so.5 Not Found

irpeitzsch
Beginner
281 Views

I am currently trying to run something on the Stratix 10 nodes on the Intel Devcloud, but when I do I get the following error:

error while loading shared libraries: libsycl.so.5: cannot open shared object file: No such file or directory

 

Does anyone know how to fix this?

0 Kudos
1 Solution
DiyaN_Intel
Moderator
228 Views

Hi ,

 

We ran mandelbrot sample on DevCloud with the old binary and got a similar error that you got.

DiyaN_Intel_0-1671694801643.png

The reason is oneAPI is updated to 2023.0 and in this "runtime of oneAPI 2023.0 is not backwards compatible". So, we can’t run the old binaries, in order to run the old binaries we need to rebuild those binaries again.

The workaround to resolve the above error is given in the screenshot below:

DiyaN_Intel_1-1671694837863.png

 

If you face any issues please connect back to us. 

If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue. Thank you!

 

Regards, 

Diya 

 

View solution in original post

6 Replies
DiyaN_Intel
Moderator
263 Views

Hi, 


Thank you for posting in Intel communities.

Could you please share the sample reproducer code so that we can try to find out the issue from our end.


Regards,

Diya


JVand22
Beginner
238 Views

I've been having the same issue for a few days - the libsycl.so.5 error comes up when running any synthesized S10 design (even those that ran without issue before). I've checked multiple Stratix 10 nodes - s001-n142/n143/n144. Any updates on this?

DiyaN_Intel
Moderator
229 Views

Hi ,

 

We ran mandelbrot sample on DevCloud with the old binary and got a similar error that you got.

DiyaN_Intel_0-1671694801643.png

The reason is oneAPI is updated to 2023.0 and in this "runtime of oneAPI 2023.0 is not backwards compatible". So, we can’t run the old binaries, in order to run the old binaries we need to rebuild those binaries again.

The workaround to resolve the above error is given in the screenshot below:

DiyaN_Intel_1-1671694837863.png

 

If you face any issues please connect back to us. 

If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue. Thank you!

 

Regards, 

Diya 

 

jbick819
Novice
205 Views
Hello,

Is there a way to use the old runtime for executing older binaries since this new version isn't backwards compatible?

My project works on the previous version of oneAPI and not the 2023.0 update, so I've been strictly using that older version for my project.

Thank you!
DiyaN_Intel
Moderator
147 Views

Hi, 

 

To stay with the previous version of oneAPI, you can setvar to the previous release

 

Source the setvars.sh script to setup the 2022.3 environment by using the below command:

source /glob/development-tools/versions/oneapi/2022.3/inteloneapi/setvars.sh

or

source /glob/development-tools/versions/oneapi/2022.3/inteloneapi/setvars.sh --force

If this resolves your issue, make sure to accept this as a solution. 

This would help others with similar issues. Thank you!

 

Thanks and Regards, 

 

Diya

 

 

DiyaN_Intel
Moderator
123 Views

Hi,


Glad to know that your issue is resolved. If you need any further assistance, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Alekhya



Reply