Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1713 Discussions

man giving "permission denied" for local man pages

User01
New Contributor II
2,268 Views

As part of the work-around I had to implement for the out-of-date CMake on DevCloud, I installed the latest CMake in my $HOME directory. I added the following to my ~/.bashrc which includes setting the MANPATH:

# CMake 3.23.2
export PATH="${HOME}"/opt/cmake-3.23.2-linux-x86_64/bin:"${PATH}"
export MANPATH="${HOME}"/opt/cmake-3.23.2-linux-x86_64/man:"${MANPATH}"
source "${HOME}"/opt/cmake-3.23.2-linux-x86_64/share/bash-completion/completions/cmake
source "${HOME}"/opt/cmake-3.23.2-linux-x86_64/share/bash-completion/completions/cpack
source "${HOME}"/opt/cmake-3.23.2-linux-x86_64/share/bash-completion/completions/ctest

When I try to access the man page for the 3.23.2 installation, man gives a "permission denied" error. I am running man as my user account, which has read/write on the cmake.1 file and read/write/execute on all the directories in the hierarchy.

$ man -l /home/u123456/opt/cmake-3.23.2-linux-x86_64/man/man1/
cmake.1
man: /home/u123456/opt/cmake-3.23.2-linux-x86_64/man/man1/cmake.1: Permission denied

I have not seen this behavior with MANPATH on other systems. Are there any suggestions for setting MANPATH on Intel DevCloud?

0 Kudos
12 Replies
User01
New Contributor II
2,266 Views

If I take the same cmake.1 file and copy it to $PBS_SCRATCHDIR, then man works as expected.

man -l $PBS_SCRATCHDIR/cmake.1

 

0 Kudos
AlekhyaV_Intel
Moderator
2,230 Views

Hi,


Thank you for posting in Intel Communities. In DevCloud, /opt or any folders beneath that doesn't have write/execute permissions. Hence you are getting the "Permission denied" error. Please try to install in a different directory and see if the issue still persists.


If this resolves your issue, please make sure to accept this as a solution. This might help others with similar issue. Thank you.


Regards,

Alekhya


0 Kudos
User01
New Contributor II
2,225 Views

I am not using "/opt" off the root directory. I have an "opt" subfolder under my home directory. I happen to name my subdirectory "opt" as well. As per the example above, "/home/u123456/opt/" is not the same directory as "/opt."

0 Kudos
AlekhyaV_Intel
Moderator
2,218 Views

Hi,


Could you please rename your new "/opt" folder to any other name and see if the issue still persists?


Regards,

Alekhya


0 Kudos
User01
New Contributor II
2,191 Views

I copied from ~/opt to ~ and I still get permission denied from man when reading a file I have access to read and write.

u123456@s001-n061:~$ man --local-file ~/opt/singularity-ce-3.10.2/share/man/man1/singularity.1
man: /home/u123456/opt/singularity-ce-3.10.2/share/man/man1/singularity.1: Permission denied
u123456@s001-n061:~$ cp ~/opt/singularity-ce-3.10.2/share/man/man1/singularity.1 ~
u123456@s001-n061:~$ man --local-file ~/singularity.1
man: /home/u123456/singularity.1: Permission denied
u123456@s001-n061:~$ head ~/singularity.1
.nh
.TH "singularity" "1" "Jul 2022" "Auto generated by spf13/cobra" ""

.SH NAME
.PP
singularity -
Linux container platform optimized for High Performance Computing (HPC) and
Enterprise Performance Computing (EPC)

 

0 Kudos
AlekhyaV_Intel
Moderator
2,154 Views

Hi,

 

As you've installed another CMake version in the DevCloud home directory, please check whether you gave all the necessary permissions to the CMake folder as below:

 

chmod -R 777 ./<folder_name>

 

Please let us know if the issue still persists.

If this resolves your issue, make sure to accept this as a solution. This might help others with similar issue. Thank you!

 

Regards,

Alekhya

 

0 Kudos
AlekhyaV_Intel
Moderator
2,134 Views

Hi,

 

We got an update from the admin team regarding this issue. We already support cmake 3.21.2. Here's how you can access it:

 

$ module load cmake/3.21.2

 

or

 

$ module load cmake

 

The above works due to the fact that cmake 3.21.2 is the default option for loading the cmake module.

This is how you can verify that the cmake version you want has been loaded:

$ which cmake

/glob/development-tools/versions/cmake/3.21.2/bin/cmake

 

You can check what other cmake versions are available using this command:

$ module avail 

 

So, Try man command after following the above steps and see if the issue still persists. As we have provided a resolution for your request, can we discontinue monitoring this thread?

 

Regards,

Alekhya

 

 

0 Kudos
AlekhyaV_Intel
Moderator
2,100 Views

Hi,


Can we discontinue monitoring this thread? Please give us an update.


Regards,

Alekhya


0 Kudos
User01
New Contributor II
2,092 Views

I have already provided answers to all of the questions that were asked. It seems CMake as an example caused some distractions as the problem was not about CMake specifically and using the existing modulefile is not relevant to the problem of man not working. The advice to recursively set world-readable permission is a bad idea and should not be done.

Please escalate this issue to the next level of support.

0 Kudos
AlekhyaV_Intel
Moderator
2,073 Views

Hi,


We understand your concern. We need some confirmation whether you're still getting the "permission denied" error after loading modules and running man command. Please let us know.


Regards,

Alekhya


0 Kudos
AlekhyaV_Intel
Moderator
2,040 Views

Hi,


Is your issue resolved? Can we discontinue monitoring this thread? Please give us an update


Regards,

Alekhya


0 Kudos
AlekhyaV_Intel
Moderator
2,020 Views

Hi,


We assume that your issue is resolved. If you need any further assistance, please post a new thread as this thread will no longer be monitored by Intel.


Regards,

Alekhya


0 Kudos
Reply