Community
cancel
Showing results for 
Search instead for 
Did you mean: 
597 Views

Can not init Myriad device: NC_ERROR

Hi

I am getting the error: Can not init Myriad device: NC_ERROR on running inference on Intel Myriad X platform. My output is as follows

Running ./benchmark_app -m ~/intel/openvino/deployment_tools/tools/model_downloader/public/vgg16/FP16/vgg16.xml -i input1.jpg -d MYRIAD
[Step 1/11] Parsing and validating input arguments
[ INFO ] Parsing input parameters
[ INFO ] Files were added: 1
[ INFO ]     input1.jpg
[ WARNING ] -nstreams default value is determined automatically for a device. Although the automatic selection usually provides a reasonable performance,but it still may be non-optimal for some cases, for more information look at README.

[Step 2/11] Loading Inference Engine
[ INFO ] InferenceEngine:
    API version ............ 2.1
    Build .................. custom_releases/2019/R3_cb6cad9663aea3d282e0e8b3e0bf359df665d5d0
    Description ....... API
[ INFO ] Device info:
    MYRIAD
    myriadPlugin version ......... 2.1
    Build ........... 30677

[Step 3/11] Reading the Intermediate Representation network
[ INFO ] Loading network files
[ INFO ] Read network took 1821.21 ms
[Step 4/11] Resizing network to match image sizes and given batch
[ INFO ] Network batch size: 1, precision: FP16
[Step 5/11] Configuring input of the model
[Step 6/11] Setting device configuration
[Step 7/11] Loading the model to the device
W: [ncAPI] [    398792] [benchmark_app] ncDeviceOpen:651    Failed to find a device, rc: X_LINK_DEVICE_NOT_FOUND
[ ERROR ] Can not init Myriad device: NC_ERROR

I have followed all the installation steps with the Myriad Plugin but still getting this error.
Can this issue be solved?

Thanks

0 Kudos
4 Replies
JesusE_Intel
Moderator
597 Views

Hi Aditya,

Thanks for reaching out, which Myriad device are you using? 

Also, could you please answer the following questions:

  • Which version of the OpenVINO™ toolkit are you using?
  • Which Operative System are you using?
  • Could you provide the content of the /etc/udev/rules.d/*myriad*.rules?
  • What is the output of lsusb?
  • Is there a particular guide you are following?

Regards,

Jesus

597 Views

Hi

I am using the Myriad X Development Kit MV0235. I have tried using the Intel NCS2 and it worked fine with that. I just wanted to run inference using the Hardware kit MV0235.
To answer your questions:

  • I am using OpenVINO 2019 R3
  • I am on linux
  • I have updated the usbbboot rules as required
  • lsusb shows the myriad x 2458 connected when i use the NCS2 but does not show anything when i connect the Hardware Kit
    • The hardware kit is connected via JTAG so i am not sure if OpenVINO can detect the Myriad X. Is there anything i need to do for it to detect JTAG? I am not aware of this since it is new to me
  • I followed the Hardware Kit installation guide using Movidius MDK installlation instructions. I am just trying to see if inference can be run using OpenVINO

Thanks and Regards

Aditya

Luis_at_Intel
Moderator
597 Views

Hi Chakravarthy, Aditya,

It looks like you are using the Myriad X Development Kit (MDK). I am not sure if you will be able to run Inference on such device, I'd suggest to reach out directly to the field engineer who provided you with the MDK for this and any other MDK questions you may have.

In case you don't have their contact information, let me know so we can look for the proper team and put you in contact with them. If you can please send me a Private Message with your contact information as well, so I can forward it to the team as well (Name, Email, Company).

 

Regards,

Luis

597 Views

Hi

I read on another forum, OpenVINO does not have support for Movidius Myriad Development Kit and the MV0235. So I will continue running inference using the Intel NCS2 itself since it is not possible on this device.

Thanks and regards,

Aditya

Reply