Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.

Can't find the iGPU in WSL2

Mostafa-
Employee
370 Views

Hello All,

 

I tried to run OpenVINO code on my iGPU (I already install all the prerequisites to run OpenVINO on my iGPU ), but I can't! so I think it seems that WSL2 can't find my iGPU.

 

And I tried to use inxi -G to list the iGPU through WSL2, but I got the below response.

Mostafa_0-1639209370017.png

 

I have Intel® Core™ i7-10610U CPU @ 1.80GHz with Intel® UHD Graphics

Mostafa_1-1639209370315.png

 

thanks,

Mostafa

0 Kudos
1 Solution
Hairul_Intel
Moderator
326 Views

Hi Mostafa,

Thank you for reaching out to us.

 

WSL2 does not support for Intel GPU plugin. You can check the available device plugins on your WSL2 subsystem by using Hello Query Device Python* Sample.

 

This issue has also been discussed on this previous thread.

 

 

Regards,

Hairul


View solution in original post

2 Replies
Hairul_Intel
Moderator
327 Views

Hi Mostafa,

Thank you for reaching out to us.

 

WSL2 does not support for Intel GPU plugin. You can check the available device plugins on your WSL2 subsystem by using Hello Query Device Python* Sample.

 

This issue has also been discussed on this previous thread.

 

 

Regards,

Hairul


Hairul_Intel
Moderator
303 Views

Hi Mostafa,

This thread will no longer be monitored since this issue has been resolved. If you need any additional information from Intel, please submit a new question.

 

 

Regards,

Hairul


Reply