Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Aman_Vishen
Beginner
122 Views

Configure the Model Optimizer

When i install tensorFlow it ask for specific version of numpy so i install that version but when when i install mxnet it again ask for different version of numpy

there is numpy compatibility issue

Error code--

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

tensorboard 2.3.0 requires requests<3,>=2.21.0, but you'll have requests 2.18.4 which is incompatible.

0 Kudos
2 Replies
Iffa_Intel
Moderator
111 Views

Greetings,


First and foremost, can you clarify whether you are using TF1 or TF2?

If you are using TF2, you can refer here to ensure correct setup:


Since you mentioned mxnet, I presume you are trying to convert mxnet model to IR and use it with Openvino. Please help to refer to this official documentation to ensure your custom model is supported: https://docs.openvinotoolkit.org/latest/openvino_docs_MO_DG_prepare_model_convert_model_Convert_Mode...


By default, if you had done the install_prerequisites.sh correctly, you won't have any problems afterwards :https://docs.openvinotoolkit.org/latest/openvino_docs_MO_DG_prepare_model_Config_Model_Optimizer.htm...



probably you can try to do it manually bu running:

install_prerequisites_mxnet.sh for Linux

install_prerequisites_mxnet.bat for Windows



Sincerely,

Iffa


Iffa_Intel
Moderator
98 Views

Greetings,


Intel will no longer monitor this thread since we have provided a solution. If you need any additional information from Intel, please submit a new question. 


Sincerely,

Iffa


Reply