Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
65 Views

Demo on Neural Compute Stick-2

Jump to solution

Hi, I am new to OpenVINO and Neural Compute Stick-2. I just got my Neural Compute stick and was desperate to give it a try but unsuccessful.  I am trying to run Demo app after installing OpenVINO (following step from this link https://docs.openvinotoolkit.org/2019_R2/_docs_install_guides_installing_openvino_windows.html#set-the-environment-variables). I get below error when running the demo app. Can someone please check and help my .xml file is not getting created or found in the required path?

 

 

C:\Users\venku>cd C:\Program Files (x86)\IntelSWTools\openvino\bin\

C:\Program Files (x86)\IntelSWTools\openvino\bin>setupvars.bat
Python 3.6.0
ECHO is off.
PYTHONPATH=C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\accuracy_checker;C:\Program Files (x86)\IntelSWTools\openvino\python\python3.6;C:\Program Files (x86)\IntelSWTools\openvino\python\python3;
[setupvars.bat] OpenVINO environment initialized

C:\Program Files (x86)\IntelSWTools\openvino\bin>C:

C:\Program Files (x86)\IntelSWTools\openvino\bin>cd C:\"Program Files (x86)"\IntelSWTools\openvino\deployment_tools\demo

C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo>.\demo_squeezenet_download_convert_run.bat -d MYRIAD
target = MYRIAD
target_precision = FP16
Python 3.6.0
ECHO is off.
PYTHONPATH=C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\accuracy_checker;C:\Program Files (x86)\IntelSWTools\openvino\python\python3.6;C:\Program Files (x86)\IntelSWTools\openvino\python\python3;C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\accuracy_checker;C:\Program Files (x86)\IntelSWTools\openvino\python\python3.6;C:\Program Files (x86)\IntelSWTools\openvino\python\python3;
[setupvars.bat] OpenVINO environment initialized
INTEL_OPENVINO_DIR is set to C:\Program Files (x86)\IntelSWTools\openvino
Python 3.6.0
ECHO is off.
Requirement already satisfied: pyyaml in c:\users\venku\appdata\roaming\python\python36\site-packages (from -r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 1))
Requirement already satisfied: requests in c:\users\venku\appdata\roaming\python\python36\site-packages (from -r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 2))
Requirement already satisfied: urllib3<1.23,>=1.21.1 in c:\users\venku\appdata\roaming\python\python36\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 2))
Requirement already satisfied: certifi>=2017.4.17 in c:\users\venku\appdata\roaming\python\python36\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 2))
Requirement already satisfied: idna<2.7,>=2.5 in c:\users\venku\appdata\roaming\python\python36\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 2))
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in c:\users\venku\appdata\roaming\python\python36\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 2))
You are using pip version 9.0.1, however version 19.3.1 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.
Download public squeezenet1.1 model

Models have been loaded previously. Skip loading model step.
Model path: C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16\public\squeezenet1.1\squeezenet1.1.prototxt
python "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\downloader\downloader.py" --name squeezenet1.1 --output_dir C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16 --cache_dir C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\ir\cache
################|| Downloading models ||################

========== Retrieving C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16\public\squeezenet1.1\squeezenet1.1.prototxt from the cache

========== Retrieving C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16\public\squeezenet1.1\squeezenet1.1.caffemodel from the cache

################|| Post-processing ||################

========== Replacing text in C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16\public\squeezenet1.1\squeezenet1.1.prototxt
squeezenet1.1 model downloading completed

Waiting for 0 seconds, press a key to continue ...

Target folder C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\ir\FP16\public\squeezenet1.1 already exists. Skipping IR generation with Model Optimizer.
If you want to convert a model again, remove the entire C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\ir\FP16\public\squeezenet1.1 folder.

Waiting for 0 seconds, press a key to continue ...

###############|| Generate VS solution for Inference Engine samples using cmake ||###############


Waiting for 0 seconds, press a key to continue ...
Creating Visual Studio 16 2019 x64 files in C:\Users\venku\Documents\Intel\OpenVINO\inference_engine_samples_build...
-- The C compiler identification is MSVC 19.23.28106.4
-- The CXX compiler identification is MSVC 19.23.28106.4
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.23.28105/bin/Hostx64/x64/cl.exe
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.23.28105/bin/Hostx64/x64/cl.exe -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.23.28105/bin/Hostx64/x64/cl.exe
-- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.23.28105/bin/Hostx64/x64/cl.exe -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Check size of __int32
-- Check size of __int32 - done
-- Found InferenceEngine: C:/Program Files (x86)/IntelSWTools/openvino/deployment_tools/inference_engine/lib/intel64/Release/inference_engine.lib (Required is at least version "2.1")
-- Performing Test HAVE_CPUID_INFO
-- Performing Test HAVE_CPUID_INFO - Success
-- Host CPU features:
--   3DNOW not supported
--   3DNOWEXT not supported
--   ABM not supported
--   ADX supported
--   AES supported
--   AVX supported
--   AVX2 supported
--   AVX512CD not supported
--   AVX512F not supported
--   AVX512ER not supported
--   AVX512PF not supported
--   BMI1 supported
--   BMI2 supported
--   CLFSH supported
--   CMPXCHG16B supported
--   CX8 supported
--   ERMS supported
--   F16C supported
--   FMA supported
--   FSGSBASE supported
--   FXSR supported
--   HLE supported
--   INVPCID supported
--   LAHF supported
--   LZCNT supported
--   MMX supported
--   MMXEXT not supported
--   MONITOR not supported
--   MOVBE supported
--   MSR supported
--   OSXSAVE supported
--   PCLMULQDQ supported
--   POPCNT supported
--   PREFETCHWT1 not supported
--   RDRAND supported
--   RDSEED supported
--   RDTSCP supported
--   RTM supported
--   SEP supported
--   SHA not supported
--   SSE supported
--   SSE2 supported
--   SSE3 supported
--   SSE4.1 supported
--   SSE4.2 supported
--   SSE4a not supported
--   SSSE3 supported
--   SYSCALL supported
--   TBM not supported
--   XOP not supported
--   XSAVE supported
-- TBB include: C:/Program Files (x86)/IntelSWTools/openvino/deployment_tools/inference_engine/external/tbb/include
-- TBB Release lib: C:/Program Files (x86)/IntelSWTools/openvino/deployment_tools/inference_engine/lib/intel64/Release/tbb.lib
-- TBB Debug lib: C:/Program Files (x86)/IntelSWTools/openvino/deployment_tools/inference_engine/lib/intel64/Debug/tbb_debug.lib
-- Looking for pthread.h
-- Looking for pthread.h - not found
-- Found Threads: TRUE
-- Configuring done
-- Generating done
-- Build files have been written to: C:/Users/venku/Documents/Intel/OpenVINO/inference_engine_samples_build

Waiting for 0 seconds, press a key to continue ...

###############|| Build Inference Engine samples using MS Visual Studio (MSBuild.exe) ||###############


Waiting for 0 seconds, press a key to continue ...
C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\Bin\MSBuild.exe" Samples.sln /p:Configuration=Release /t:classification_sample_async /clp:ErrorsOnly /m
Microsoft (R) Build Engine version 16.3.1+1def00d3d for .NET Framework
Copyright (C) Microsoft Corporation. All rights reserved.


Waiting for 0 seconds, press a key to continue ...

###############|| Run Inference Engine classification sample ||###############


Waiting for 0 seconds, press a key to continue ...
        1 file(s) copied.
classification_sample_async.exe -i "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\car.png" -m "C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\ir\FP16\public\squeezenet1.1\squeezenet1.1.xml" -d MYRIAD
[ INFO ] InferenceEngine:
        API version ............ 2.1
        Build .................. 30677
        Description ....... API
[ INFO ] Parsing input parameters
[ INFO ] Parsing input parameters
[ INFO ] Files were added: 1
[ INFO ]     C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\car.png
[ INFO ] Creating Inference Engine
        MYRIAD
        myriadPlugin version ......... 2.1
        Build ........... 30677

[ INFO ] Loading network files
[ ERROR ] Error loading xmlfile: C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\ir\FP16\public\squeezenet1.1\squeezenet1.1.xml, File was not found at line: 1 pos: 0
Error

C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo>
 

0 Kudos

Accepted Solutions
Highlighted
Moderator
65 Views

Hi Venku,

I believe there is a compatibility issue with the networkx package. Could you try and install version 2.3 using the command "pip3 install networkx==2.3".

Try to run the demo again and let me know if it works. You may need to delete the directory once more. 

Regards,

Jesus

View solution in original post

0 Kudos
8 Replies
Highlighted
Moderator
65 Views

Hi Venku,

Did you try to run the demo once and it failed? If so, the directory was created and when the demo runs the second time it skips the model conversion as the directory already exists. Please try to delete the squeezenet1.1 directory and re-run the demo.

C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\ir\FP16\public\squeezenet1.1

Let me know if you see a different error. 

Regards,

Jesus

0 Kudos
Highlighted
Novice
65 Views

Hi Jesus, I deleted the folder and reran it. This is the error I get now. Can you please suggest what is wrong here. In fact when I tried to convert a pre-trained Tensorflow model to IR (.bin and .xml) files I am getting the same exact error. 

 

C:\Program Files (x86)\IntelSWTools\openvino\bin>cd C:\Program Files (x86)\IntelSWTools\openvino\bin\

C:\Program Files (x86)\IntelSWTools\openvino\bin>setupvars.bat
Python 3.6.5
ECHO is off.
PYTHONPATH=C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\accuracy_checker;C:\Program Files (x86)\IntelSWTools\openvino\python\python3.6;C:\Program Files (x86)\IntelSWTools\openvino\python\python3;C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\accuracy_checker;C:\Program Files (x86)\IntelSWTools\openvino\python\python3.6;C:\Program Files (x86)\IntelSWTools\openvino\python\python3;
[setupvars.bat] OpenVINO environment initialized

C:\Program Files (x86)\IntelSWTools\openvino\bin>cd C:\"Program Files (x86)"\IntelSWTools\openvino\deployment_tools\demo

C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo>.\demo_squeezenet_download_convert_run.bat -d MYRIAD
target = MYRIAD
target_precision = FP16
Python 3.6.5
ECHO is off.
PYTHONPATH=C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\accuracy_checker;C:\Program Files (x86)\IntelSWTools\openvino\python\python3.6;C:\Program Files (x86)\IntelSWTools\openvino\python\python3;C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\accuracy_checker;C:\Program Files (x86)\IntelSWTools\openvino\python\python3.6;C:\Program Files (x86)\IntelSWTools\openvino\python\python3;C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\accuracy_checker;C:\Program Files (x86)\IntelSWTools\openvino\python\python3.6;C:\Program Files (x86)\IntelSWTools\openvino\python\python3;
[setupvars.bat] OpenVINO environment initialized
INTEL_OPENVINO_DIR is set to C:\Program Files (x86)\IntelSWTools\openvino
Python 3.6.5
ECHO is off.
Requirement already satisfied: pyyaml in c:\users\venku\appdata\roaming\python\python36\site-packages (from -r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 1))
Requirement already satisfied: requests in c:\users\venku\appdata\roaming\python\python36\site-packages (from -r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 2))
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in c:\users\venku\appdata\roaming\python\python36\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 2))
Requirement already satisfied: idna<2.7,>=2.5 in c:\users\venku\appdata\roaming\python\python36\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 2))
Requirement already satisfied: certifi>=2017.4.17 in c:\users\venku\appdata\roaming\python\python36\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 2))
Requirement already satisfied: urllib3<1.23,>=1.21.1 in c:\users\venku\appdata\roaming\python\python36\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\..\open_model_zoo\tools\downloader\requirements.in (line 2))
You are using pip version 9.0.3, however version 19.3.1 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.
Download public squeezenet1.1 model
python "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\downloader\downloader.py" --name squeezenet1.1 --output_dir C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16 --cache_dir C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\ir\cache
################|| Downloading models ||################

========== Downloading C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16\public\squeezenet1.1\squeezenet1.1.prototxt


========== Downloading C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16\public\squeezenet1.1\squeezenet1.1.caffemodel
... 100%, 4834 KB, 9368 KB/s, 0 seconds passed

################|| Post-processing ||################

========== Replacing text in C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16\public\squeezenet1.1\squeezenet1.1.prototxt
squeezenet1.1 model downloading completed

Waiting for 0 seconds, press a key to continue ...

###############|| Install Model Optimizer prerequisites ||###############


Waiting for 0 seconds, press a key to continue ...
Python 3.6.5
ECHO is off.
Requirement already satisfied: networkx>=1.11 in c:\users\venku\appdata\roaming\python\python36\site-packages (from -r ..\requirements_caffe.txt (line 1))
Requirement already satisfied: numpy>=1.12.0 in c:\users\venku\appdata\roaming\python\python36\site-packages (from -r ..\requirements_caffe.txt (line 2))
Requirement already satisfied: protobuf==3.6.1 in c:\users\venku\appdata\roaming\python\python36\site-packages (from -r ..\requirements_caffe.txt (line 3))
Requirement already satisfied: defusedxml>=0.5.0 in c:\users\venku\appdata\roaming\python\python36\site-packages (from -r ..\requirements_caffe.txt (line 4))
Requirement already satisfied: decorator>=4.3.0 in c:\users\venku\appdata\roaming\python\python36\site-packages (from networkx>=1.11->-r ..\requirements_caffe.txt (line 1))
Requirement already satisfied: six>=1.9 in c:\users\venku\appdata\roaming\python\python36\site-packages (from protobuf==3.6.1->-r ..\requirements_caffe.txt (line 3))
Requirement already satisfied: setuptools in c:\users\venku\appdata\roaming\python\python36\site-packages (from protobuf==3.6.1->-r ..\requirements_caffe.txt (line 3))
You are using pip version 9.0.3, however version 19.3.1 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.
*****************************************************************************************
Warning: please expect that Model Optimizer conversion might be slow.
You can boost conversion speed by installing protobuf-*.egg located in the
"model-optimizer\install_prerequisites" folder or building protobuf library from sources.
For more information please refer to Model Optimizer FAQ, question #80.

Waiting for 0 seconds, press a key to continue ...

###############|| Run Model Optimizer ||###############


Waiting for 0 seconds, press a key to continue ...
python mo.py --input_model "C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16\public\squeezenet1.1\squeezenet1.1.caffemodel" --output_dir "C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\ir\FP16\public\squeezenet1.1" --data_type FP16
Model Optimizer arguments:
Common parameters:
        - Path to the Input Model:      C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16\public\squeezenet1.1\squeezenet1.1.caffemodel
        - Path for generated IR:        C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\ir\FP16\public\squeezenet1.1
        - IR output name:       squeezenet1.1
        - Log level:    ERROR
        - Batch:        Not specified, inherited from the model
        - Input layers:         Not specified, inherited from the model
        - Output layers:        Not specified, inherited from the model
        - Input shapes:         Not specified, inherited from the model
        - Mean values:  Not specified
        - Scale values:         Not specified
        - Scale factor:         Not specified
        - Precision of IR:      FP16
        - Enable fusing:        True
        - Enable grouped convolutions fusing:   True
        - Move mean values to preprocess section:       False
        - Reverse input channels:       False
Caffe specific parameters:
        - Path to Python Caffe* parser generated from caffe.proto:      mo\front\caffe\proto
        - Enable resnet optimization:   True
        - Path to the Input prototxt:   C:\Users\venku\Documents\Intel\OpenVINO\openvino_models\models\FP16\public\squeezenet1.1\squeezenet1.1.prototxt
        - Path to CustomLayersMapping.xml:      extensions\front\caffe\CustomLayersMapping.xml
        - Path to a mean file:  Not specified
        - Offsets for a mean file:      Not specified
Model Optimizer version:        2019.3.0-375-g332562022
[ ERROR ]  -------------------------------------------------
[ ERROR ]  ----------------- INTERNAL ERROR ----------------
[ ERROR ]  Unexpected exception happened.
[ ERROR ]  Please contact Model Optimizer developers and forward the following information:
[ ERROR ]  'Graph' object has no attribute 'node'
[ ERROR ]  Traceback (most recent call last):
  File "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\model_optimizer\mo\main.py", line 302, in main
    return driver(argv)
  File "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\model_optimizer\mo\main.py", line 261, in driver
    custom_layers_mapping_path=custom_layers_mapping_path)
  File "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\model_optimizer\mo\pipeline\caffe.py", line 65, in driver
    graph, original_shapes = loader.caffe_pb_to_nx(proto, model)
  File "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\model_optimizer\mo\front\caffe\loader.py", line 294, in caffe_pb_to_nx
    graph.add_node(layer.name, pb=layer, model_pb=model_layer, kind='op', type='Parameter')
  File "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\model_optimizer\mo\graph\graph.py", line 505, in add_node
    node.update_node()
  File "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\model_optimizer\mo\graph\graph.py", line 470, in update_node
    in_ports_count = self.in_ports_count if self.has_valid('in_ports_count') else None
  File "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\model_optimizer\mo\graph\graph.py", line 161, in has_valid
    return self.has(k) and not self.graph.node[self.node] is None
  File "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\model_optimizer\mo\graph\graph.py", line 158, in has
    return k in self.graph.node[self.node]
AttributeError: 'Graph' object has no attribute 'node'

[ ERROR ]  ---------------- END OF BUG REPORT --------------
[ ERROR ]  -------------------------------------------------
Error

0 Kudos
Highlighted
Moderator
66 Views

Hi Venku,

I believe there is a compatibility issue with the networkx package. Could you try and install version 2.3 using the command "pip3 install networkx==2.3".

Try to run the demo again and let me know if it works. You may need to delete the directory once more. 

Regards,

Jesus

View solution in original post

0 Kudos
Highlighted
Novice
65 Views

That's it! This did the trick. I am able to run the demo now. Thank you so much Jesus.

0 Kudos
Highlighted
Novice
65 Views

Jesus, while you are here, can I ask you another quick question please? I know this not the correct way to ask a question but I am hitting my head on this for a while.

For working with Python and NCS2 on Raspberry Pi, can you please point me to the correct tutorial or documentation? I followed this first to setup openVINO - https://docs.openvinotoolkit.org/latest/_docs_install_guides_installing_openvino_raspbian.html and then I came accross this (https://software.intel.com/en-us/articles/python3-sbc-and-ncs2) and tried to follow these steps but after "sudo make install" step, opencv is no longer linked to Python3.7 when I try "python3" and "import cv2" it does not import. It looks like, it has linked to my python 2.7 instead. when I run just try "python" it opens 2.7 installation and then when I try "import cv2" it work here. How do change cv2 to point to python3 instead of python (2.7) please?

 

 

0 Kudos
Highlighted
Moderator
65 Views

Hi Venku,

The Install OpenVINO™ toolkit for Raspbian* OS should already have everything you need to start coding in python. This is the pre-built package with OpenVINO. The second guide you are following are steps to follow if you are building the OpenVINO toolkit from source using the open-sourced version on other ARM single board computers. 

I recommend starting again and simply follow the first guide.

Regards,

Jesus

0 Kudos
Highlighted
Novice
65 Views

Thank you  again Jesus!

0 Kudos
Highlighted
Novice
65 Views

Thank you  again Jesus!

0 Kudos