Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Darmana__Budi
Beginner
148 Views

OpenVINO™ toolkit 2019 R3 Model Optimizer Error in Windows 10

Hi....

I install OpenVINO™ toolkit 2019 R3 for Windows and python 3.6.5. I got problem running model optimizer with following message:

C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\model_optimizer>python mo_caffe.py --input_model "C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\tools\model_downloader\public\squeezenet1.1\squeezenet1.1.caffemodel"
Model Optimizer arguments:
Common parameters:
        - Path to the Input Model:      C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\tools\model_downloader\public\squeezenet1.1\squeezenet1.1.caffemodel
        - Path for generated IR:        C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\model_optimizer\.
        - IR output name:       squeezenet1.1
        - Log level:    ERROR
        - Batch:        Not specified, inherited from the model
        - Input layers:         Not specified, inherited from the model
        - Output layers:        Not specified, inherited from the model
        - Input shapes:         Not specified, inherited from the model
        - Mean values:  Not specified
        - Scale values:         Not specified
        - Scale factor:         Not specified
        - Precision of IR:      FP32
        - Enable fusing:        True
        - Enable grouped convolutions fusing:   True
        - Move mean values to preprocess section:       False
        - Reverse input channels:       False
Caffe specific parameters:
        - Path to Python Caffe* parser generated from caffe.proto:      mo\front\caffe\proto
        - Enable resnet optimization:   True
        - Path to the Input prototxt:   C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\tools\model_downloader\public\squeezenet1.1\squeezenet1.1.prototxt
        - Path to CustomLayersMapping.xml:      extensions\front\caffe\CustomLayersMapping.xml
        - Path to a mean file:  Not specified
        - Offsets for a mean file:      Not specified
Model Optimizer version:        2019.3.0-375-g332562022
[ ERROR ]  -------------------------------------------------
[ ERROR ]  ----------------- INTERNAL ERROR ----------------
[ ERROR ]  Unexpected exception happened.
[ ERROR ]  Please contact Model Optimizer developers and forward the following information:
[ ERROR ]  'Graph' object has no attribute 'node'
[ ERROR ]  Traceback (most recent call last):
  File "C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\model_optimizer\mo\main.py", line 302, in main
    return driver(argv)
  File "C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\model_optimizer\mo\main.py", line 261, in driver
    custom_layers_mapping_path=custom_layers_mapping_path)
  File "C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\model_optimizer\mo\pipeline\caffe.py", line 65, in driver
    graph, original_shapes = loader.caffe_pb_to_nx(proto, model)
  File "C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\model_optimizer\mo\front\caffe\loader.py", line 294, in caffe_pb_to_nx
    graph.add_node(layer.name, pb=layer, model_pb=model_layer, kind='op', type='Parameter')
  File "C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\model_optimizer\mo\graph\graph.py", line 505, in add_node
    node.update_node()
  File "C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\model_optimizer\mo\graph\graph.py", line 470, in update_node
    in_ports_count = self.in_ports_count if self.has_valid('in_ports_count') else None
  File "C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\model_optimizer\mo\graph\graph.py", line 161, in has_valid
    return self.has(k) and not self.graph.node[self.node] is None
  File "C:\Program Files (x86)\IntelSWTools\openvino_2019.3.334\deployment_tools\model_optimizer\mo\graph\graph.py", line 158, in has
    return k in self.graph.node[self.node]
AttributeError: 'Graph' object has no attribute 'node'

[ ERROR ]  ---------------- END OF BUG REPORT --------------
[ ERROR ]  -------------------------------------------------

I search around this forum and google and have no solution yet. I some body got answer for this?

 

 

Thanks and Regards

 

 

 

0 Kudos
2 Replies
Moiseev__Nikita
Beginner
148 Views

Hi,

I've also written about this problem in https://software.intel.com/en-us/forums/computer-vision/topic/830312.

Try installing python package NetworkX version 2.3. It solved the problem for me.

Thanks.

Darmana__Budi
Beginner
148 Views

Yes...it is worked. Thanks a lot!

Reply