Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
320 Views

[Error 5] Toolkit Error: Stage Details Not Supported: Square

Hi, I try to run my own model with ncsdk, and my system is ubuntu16.04. I run the code in virtual environment, I find solutions online which is downupgrading tensorflow from 1.6 into 1.3, and I tried this, but I still get this error. Any help would be appreciated.

 

@Tome_at_Intel
0 Kudos
6 Replies
Highlighted
Community Manager
37 Views

https://github.com/Derekabc/Movidius-keras there is my code.

 

Firstly, I train the model by keras, and then I convert it into tensorflow model.

 

Secondly. I use the command below to check, compile, profile the model into graph file.

 

 

mvNCCheck TF_Model/tf_model.meta -in=conv2d_1_input -on=dense_2/Softmax

 

mvNCCompile TF_Model/tf_model.meta -in=conv2d_1_input -on=dense_2/Softmax

 

mvNCProfile TF_Model/tf_model.meta -in=conv2d_1_input -on=dense_2/Softmax

 

0 Kudos
Highlighted
Community Manager
37 Views

@DongDong It would save me a lot of time if you could provide a link to your meta/index files so that I can test them. Thanks.

0 Kudos
Highlighted
Community Manager
37 Views

Thank you for your reply. I have updated the meta/index files on Github.

 

And the command for compiling, Checking and profiling as following.

 

mvNCCheck TF_Model/tf_model.meta -in=input_1 -on=dense_1/Softmax mvNCCompile TF_Model/tf_model.meta -in=input_1 -on=dense_1/Softmax mvNCProfile TF_Model/tf_model.meta -in=input_1 -on=dense_1/Softmax

 

Thank you very much!!
0 Kudos
Highlighted
Community Manager
37 Views

0 Kudos
Highlighted
Community Manager
37 Views

@DongDong Thank you for providing your model files. We were able to reproduce your issue and are looking into the issue.

0 Kudos
Highlighted
Community Manager
37 Views

@Tome_at_Intel Thank you Tome, I am looking forward to your reply! I have struggled against this error for one week!

0 Kudos