Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.
5763 Discussions

GLib.Error: gst_parse_error: no element "gvadetect" (1)

akshya
Employee
793 Views

Hi All,

I am trying to run a dlstreamer sample from OpenVINO toolkit release 2021.2 on Ubuntu 18.04.5 LTS and getting the following error. and my cmake version is 3.18.6.

/opt/intel/openvino_2021/data_processing/dl_streamer/samples/python/draw_face_attributes$ ./draw_face_attributes.sh /home/ubuntu/Downloads/video1.mp4
Running sample with the following parameters:
GST_PLUGIN_PATH=/opt/intel/openvino_2021/data_processing/dl_streamer/lib:/opt/intel/openvino_2021/data_processing/gstreamer/lib/gstreamer-1.0
filesrc location=/home/ubuntu/Downloads/video1.mp4 ! decodebin !     videoconvert n-threads=4 ! capsfilter caps="video/x-raw,format=BGRx" !     gvadetect model=/home/ubuntu/intel/dl_streamer/models/intel/face-detection-adas-0001/FP32/face-detection-adas-0001.xml device=CPU ! queue !     gvainference model=/home/ubuntu/intel/dl_streamer/models/intel/age-gender-recognition-retail-0013/FP32/age-gender-recognition-retail-0013.xml device=CPU inference-region=roi-list ! queue !     gvainference model=/home/ubuntu/intel/dl_streamer/models/intel/emotions-recognition-retail-0003/FP32/emotions-recognition-retail-0003.xml device=CPU inference-region=roi-list ! queue !     gvainference model=/home/ubuntu/intel/dl_streamer/models/intel/facial-landmarks-35-adas-0002/FP32/facial-landmarks-35-adas-0002.xml device=CPU inference-region=roi-list ! queue !     gvawatermark name=gvawatermark ! videoconvert n-threads=4 !     fpsdisplaysink video-sink=xvimagesink sync=false
Traceback (most recent call last):
  File "./draw_face_attributes.py", line 137, in <module>
    pipeline = Gst.parse_launch(gst_launch_string)
GLib.Error: gst_parse_error: no element "gvadetect" (1)

Labels (1)
0 Kudos
1 Solution
Zulkifli_Intel
Moderator
743 Views

Hello Akshya Subudhi,

 

Thank you for contacting us.

 

Try to reinstall the dependencies.

cd /opt/intel/openvino_2021/install_dependencies

sudo -E ./install_openvino_dependencies.sh

 

Let us know if you encounter any issues installing dependencies.

 

Regards,

Zulkifli

View solution in original post

3 Replies
Zulkifli_Intel
Moderator
744 Views

Hello Akshya Subudhi,

 

Thank you for contacting us.

 

Try to reinstall the dependencies.

cd /opt/intel/openvino_2021/install_dependencies

sudo -E ./install_openvino_dependencies.sh

 

Let us know if you encounter any issues installing dependencies.

 

Regards,

Zulkifli

akshya
Employee
730 Views

Hi Zulkifli,

Sorry for the late reply, I was having some connectivity issue. As per your reply I tried to reinstall the dependencies and it worked for me. Thanks for your support.

Zulkifli_Intel
Moderator
720 Views

Hello Akshya,


This thread will no longer be monitored since this issue has been resolved. If you need any additional information from Intel, please submit a new question.


Regards,

Zulkifli


Reply