Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
350 Views

[Informal] Supported/Unsupported Tensorflow layer - Cause etc. of "out of range exception ..."

If Tensorflow learning data contains an unsupported layer, an exception such as "out of range exception …" occurs when mvNNCompile is executed.

 

I checked the NCSDK v2.05 API of Tensorflow parser and found the following support status.

 

◆Supported Tensorflow layer Parser

 

Placeholder

 

Conv2D

 

MaxPool

 

AvgPool

 

Relu

 

BiasAdd

 

Concat

 

ConcatV2

 

Identity

 

Slice

 

Add

 

Mul

 

Sub

 

LRN

 

Softmax

 

FusedBatchNorm

 

Reshape

 

Pad

 

Maximum

 

RealDiv

 

◆Unsupported Tensorflow layer Parser

 

ELU

 

PReLU

 

InnerProduct

 

Dropout

 

Scale

 

Custom layer

 

I hope to support all layers.

Tags (1)
0 Kudos
1 Reply
idata
Community Manager
91 Views

I found the softmax layer cost a lot of time in ncsdk 1.12,

Reply