Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.

Jpeg 2000 support

Schoepflin__Uwe
Beginner
218 Views

Hello, the latest opencv 4.1 dll from openvino 2019R1 does not include jpeg 2000 support. Could anybody please kindly ecplain how to add jpeg2000 support on openvino 2019R1?

0 Kudos
1 Solution
Maksim_S_Intel
Employee
218 Views

Here is the instruction: https://github.com/opencv/opencv/wiki/Intel%27s-Deep-Learning-Inference-Engine-backend

Here is the detection script: https://github.com/opencv/opencv/blob/master/cmake/OpenCVDetectInferenceEngine.cmake

Usually it is enough to set WITH_INF_ENGINE to ON. If it can not be detected try to set InferenceEngine_DIR option (e.g. "<openvino>/deployment_tools/inference_engine/share") or manually set INF_ENGINE_INCLUDE_DIRS and INF_ENGINE_LIB_DIRS options. If compilation fails somewhere in dnn module, try to change INF_ENGINE_RELEASE option (e.g. "2019010000").

View solution in original post

3 Replies
Maksim_S_Intel
Employee
218 Views

You'll have to build OpenCV by yourself with JasPer library support, cmake option WITH_JASPER.

Schoepflin__Uwe
Beginner
218 Views

I know. But I have to build opencv with IE support then.

But how to build opencv with IE support? (Inference Engine:            YES (2019010000 / 1.5.0))

 

 

Maksim_S_Intel
Employee
219 Views

Here is the instruction: https://github.com/opencv/opencv/wiki/Intel%27s-Deep-Learning-Inference-Engine-backend

Here is the detection script: https://github.com/opencv/opencv/blob/master/cmake/OpenCVDetectInferenceEngine.cmake

Usually it is enough to set WITH_INF_ENGINE to ON. If it can not be detected try to set InferenceEngine_DIR option (e.g. "<openvino>/deployment_tools/inference_engine/share") or manually set INF_ENGINE_INCLUDE_DIRS and INF_ENGINE_LIB_DIRS options. If compilation fails somewhere in dnn module, try to change INF_ENGINE_RELEASE option (e.g. "2019010000").

Reply