Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
356 Views

Make Install Failed

Hi, everyone.

 

I failed to install ncsdk as described on start guide website. When I'm running "make install" I'm getting the following error:

 

 

CMake Error at cmake/Dependencies.cmake:99 (find_package):

 

By not providing "FindOpenCV.cmake" in CMAKE_MODULE_PATH this project has

 

asked CMake to find a package configuration file provided by "OpenCV", but

 

CMake did not find one.

 

Could not find a package configuration file provided by "OpenCV" with any

 

of the following names:

 

OpenCVConfig.cmake opencv-config.cmake

 

Add the installation prefix of "OpenCV" to CMAKE_PREFIX_PATH or set

 

"OpenCV_DIR" to a directory containing one of the above files. If "OpenCV"

 

provides a separate development package or SDK, be sure it has been

 

installed.

 

Call Stack (most recent call first):

 

CMakeLists.txt:46 (include)

 

-- Configuring incomplete, errors occurred!

 

See also "/opt/movidius/bvlc-caffe/build/CMakeFiles/CMakeOutput.log".

 

See also "/opt/movidius/bvlc-caffe/build/CMakeFiles/CMakeError.log".

 

make[1]: Entering directory '/opt/movidius/bvlc-caffe/build'

 

make[1]: *** No rule to make target 'all'。 停止。

 

make[1]: Leaving directory '/opt/movidius/bvlc-caffe/build'

 

Installing caffe…

 

make[1]: Entering directory '/opt/movidius/bvlc-caffe/build'

 

make[1]: *** No rule to make target 'install'。 停止。

 

make[1]: Leaving directory '/opt/movidius/bvlc-caffe/build'

 

 

My configuration:

 

corf@corf-ThinkPad-E450:~/workspace/ncsdk$ lsb_release -a

 

No LSB modules are available.

 

Distributor ID: Ubuntu

 

Description: Ubuntu 16.04.2 LTS

 

Release: 16.04

 

Codename: xenial
Tags (2)
0 Kudos
11 Replies
Highlighted
Community Manager
99 Views

Same problem, the "make install" simply does not work…Frustrating…

 

More details here:

 

….

 

make[1]: Leaving directory `/opt/movidius/bvlc-caffe/build'

 

Installation failed. Error on line 485

 

…..
0 Kudos
Highlighted
Community Manager
99 Views

Managed to install by changing to previous tag on git repo. Latest is v1.10.01.01, previous one is v1.10.00.03.

 

git checkout v1.10.00.03

 

then

 

make install

 

Regarding the make examples, is another story….

0 Kudos
Highlighted
Community Manager
99 Views

I successfully made it in a new installed Ubuntu 16.04 computer.

0 Kudos
Highlighted
Community Manager
99 Views

When I run make install, after about 10 minutes, the entire vm crashes on me with all sorts of colors. This is with Ubuntu 16.04 and v1.12

0 Kudos
Highlighted
Community Manager
99 Views

@fizzgig How much memory are you setting aside for the VM? Try using at least 2 GB for your VM RAM.

0 Kudos
Highlighted
Community Manager
99 Views

I'm at 2048 with 2 cpus. And 40gb ram. I'll try increasing to 4gb and see what happens.

0 Kudos
Highlighted
Community Manager
99 Views

@fizzgig Any luck with increasing the ram?

0 Kudos
Highlighted
Community Manager
99 Views

@Tome_at_Intel Increasing the ram had no effect. Still getting the same error. I've even tried previous tags from the repo.

0 Kudos
Highlighted
Community Manager
99 Views

@fizzgig Which VM software are you using and what error message do you receive when the machine crashes?

0 Kudos
Highlighted
Community Manager
99 Views

@Tome_at_Intel I'm using VirtualBox 5.2.6 with Ubuntu 16.04. I've set the memory to 4gb from 2gb. Hard Drive space is 40gb.

 

I've also tried both the ICH9 and PIIX3 chip sets.

 

I"m not seeing any error. It's just crashing with a multi-color screen displaying with the screen resized to more of a rectangle shape. It looks like there may be text on the multi-color screen in multi-color/character built letters, but it's unreadable. It looks like it's just crashing the VM.

0 Kudos
Highlighted
Community Manager
99 Views

0 Kudos