Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
132 Views

Neural Compute Stick 2:[Error] Can not init USB device: NC_DEVICE_NOT_FOUND

Hello all, I have spent a lot of time trying to fix this error. I am using the Neural Compute Stick 2 and am simply following the Get Started Tutorial. The sample programs work perfectly fine without using the "-d MYRIAD" command, but when I use this command (which I assume utilizes strictly the neural compute stick to run the demo) I get an error saying [Error] Can not init USB device: NC_DEVICE_NOT_FOUND. This happens when the demo is loading the model to the myriadPlugin. I have double checked and made sure that the usb rules are in the udev/rules.d and also that my user is part of the users group, and they both seem to be correct. After opening usbrules, it seems to be the exact text that was specified in the command. I am using ubuntu 16.04.3 LTS on VirtualBox.

I double-checked to make sure that my computer and VirtualBox are reading the Neural Compute Stick 2, and they are reading it correctly with the correct ID until I run the script. After I run the script, I hear the "disconnect" tone on my laptop and my stick is then read as Intel Corporation VSC Loopback Device [0100]. Shortly after, the terminal tells me that it cannot find the USB device.

There was an error with symbolic links I had when I originally used the ldconfig command, but I deleted and replaced these symbolic links. There was one link however that I originally was unable to find a proper link for: /opt/intel/common/mdf/lib64/igfxcmrt64.so. I linked it to the only other file in that folder, which may have been wrong to do.

 

Any help on this error would be greatly appreciated!

0 Kudos
4 Replies
Highlighted
Employee
132 Views

May I ask where you are adding the " -d MYRIAD" ? Please try again making it the very first argument, like classification_sample.exe -d MYRIAD....plus all the other command-line arguments.

0 Kudos
Highlighted
Innovator
132 Views

Since I was using NCSDK, Virtualbox did not recognize it well. I did nothing whatever was done. While using Virtualbox, the same phenomenon occurs in OpenVINO. For my many experiences, it is not strongly recommended to use NCS / NCS2 with Virtualbox. https://github.com/PINTO0309/MobileNet-SSD-RealSense#1ncsdk-ver-not-compatible-with-ncs2 Symptoms may be improved by upgrading the version to the latest Virtualbox. Because it is very unstable and can not be used, I have not verified seriously.
0 Kudos
Highlighted
132 Views

It seems NCS2 USB device ID changes when script starts loading model to MYRIAD.

I was able to resolve it by adding a new USB device filter with VID= 03e7 and PID=f63b in addition to VID= 03e7 and PID=2485 in Virtualbox USB settings.

 

Hope this solves your problem

0 Kudos
Highlighted
Beginner
132 Views

@Nayanbuu, Purevdorj (Intel)

Thanks....worked for me

I also made the additional change of changing the usb controller setting on my VM from 2.0 to 3.0 for all my usb filters. Not sure that this contributed in anyway, but this just might help others.

0 Kudos