Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Wang__Thomas
Beginner
142 Views

OpenVINO FPGA installation problem

Hi, I'm new in OpenVINO. I followed the installation guide from https://docs.openvinotoolkit.org/2019_R1/_docs_install_guides_installing_openvino_linux_fpga.html

and successfully completed the two demos ./demo_squeezenet_download_convert_run.sh and ./demo_security_barrier_camera.sh.

But unfortunately, as I'm installing the fpga_support_files, it turns out an error at the last step: aocl diagnose.

My device is HERO

OS: Ubuntu 16.04 FPGA for OpenCL Linux x86-64

 

The details show as follows;

robot@hero:~$ source /home/robot/下載/fpga_support_files/setup_env.sh 
Adding to Path (OpenVINO AOCL)
INTELFPGAOCLSDKROOT is set to /opt/altera/aocl-pro-rte/aclrte-linux64. Using that.

Found Quartus at /opt/altera/aocl-pro-rte/aclrte-linux64/bin  will be using that

AOCL_BOARD_PACKAGE_ROOT is set to /opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1. Using that.
Adding /opt/altera/aocl-pro-rte/aclrte-linux64/bin to PATH
Adding /opt/altera/aocl-pro-rte/aclrte-linux64/host/linux64/lib to LD_LIBRARY_PATH
Adding /opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1/linux64/lib to LD_LIBRARY_PATH
[setupvars.sh] OpenVINO environment initialized
robot@hero:~$ aocl diagnose
--------------------------------------------------------------------
Warning:
No devices attached for package:
/opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1
--------------------------------------------------------------------

Unable to find the kernel mode driver.

Please make sure you have properly installed the driver. To install the driver, run
      aocl install

DIAGNOSTIC_FAILED
--------------------------------------------------------------------

Call "aocl diagnose <device-names>" to run diagnose for specified devices
Call "aocl diagnose all" to run diagnose for all devices
 

 

I'll be appreciate if anyone can give me some suggestion.

0 Kudos
4 Replies
Kenneth_C_Intel
Employee
142 Views

Hi, can you check this page https://software.intel.com/en-us/openvino-toolkit/hardware and check to see if your FPGA is one of the supported ones around the middle of the page? 

FGale7
Beginner
142 Views

Hi,

Im having the same problem, i installed Openvino 2019 R1.01 and follow the instructions on intel website to install it, i am running bot examples properly using CPU but i m not able to configure the FPGA board to run it. 

I have a Arria 10GX FPGA development kit installed according to the recommendations here:

https://docs.openvinotoolkit.org/2019_R1.01/_docs_install_guides_GX_Configure_2019R1.html

i was able to load the top.so file and max5_150.pof files. I run aocl install using the files on the fpga_suppport_files folder for the board a10_1150_sg1, reboot and then running the aocl diagnose command i got this output:

 

Adding to Path (OpenVINO AOCL)
INTELFPGAOCLSDKROOT is set to /opt/altera/aocl-pro-rte/aclrte-linux64. Using that.

aoc was not found, but aocl was found. Assuming only RTE is installed.

AOCL_BOARD_PACKAGE_ROOT is set to /opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1. Using that.
Adding /opt/altera/aocl-pro-rte/aclrte-linux64/bin to PATH
Adding /opt/altera/aocl-pro-rte/aclrte-linux64/host/linux64/lib to LD_LIBRARY_PATH
Adding /opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1/linux64/lib to LD_LIBRARY_PATH
[setupvars.sh] OpenVINO environment initialized
dennis@Laplace:~$ aocl diagnose
-----------------------------------------------------

Adding to Path (OpenVINO AOCL)
INTELFPGAOCLSDKROOT is set to /opt/altera/4.15.0-54-genericaocl-pro-rte/aclrte-linux64. Using that.

aoc was not found, but aocl was found. Assuming only RTE is installed.

AOCL_BOARD_PACKAGE_ROOT is set to /opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1. Using that.
Adding /opt/altera/aocl-pro-rte/aclrte-linux64/bin to PATH
Adding /opt/altera/aocl-pro-rte/aclrte-linux64/host/linux64/lib to LD_LIBRARY_PATH
Adding /opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1/linux64/lib to LD_LIBRARY_PATH
[setupvars.sh] OpenVINO environment initialized
dennis@Laplace:~$ aocl diagnose
--------------------------------------------------------------------
Warning:
No devices attached for package:
/opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1
--------------------------------------------------------------------4.15.0-54-generic

Unable to find the kernel mode driver.

Please make sure you have properly installed the driver. To install the driver, run
      aocl install

DIAGNOSTIC_FAILED
--------------------------------------------------------------------

Call "aocl diagnose <device-names>" to run diagnose for specified devices
Call "aocl diagnose all" to run diagnose for all devices

---------------
Warning:
No devices attached for package:
/opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1
--------------------------------------------------------------------

Unable to find the kernel mode driver.

Please make sure you have properly installed the driver. To install the driver, run
      aocl install

DIAGNOSTIC_FAILED
--------------------------------------------------------------------

Call "aocl diagnose <device-names>" to run diagnose for specified devices
Call "aocl diagnose all" to run diagnose for all devices

Does anyone knows what the problem is and how to fix it?

 

I am using Quartus 18.1 lite.

the kernel version is: 4.15.0-54-generic4.15.0-54-generic

ubuntu 16.04

 

thanks in advance.

SHENG__LEE
Beginner
142 Views

Hi,

I have met the same problem as you ,and my device is HERO platform too,I have run eveything with OpenCL OK,however ,when I installed OpenVINO and run demo_security_barrier_camera.sh.I have met the same problem as you are.may you have solved this problem?

thanks in advace.

NSVR
Novice
40 Views

Did you solve this issue. Please post here I am having this problem for the last two months