Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Xiao__Jun
Beginner
87 Views

Openvino model-optimizor Conversion error

Hi, I was following openvino github  https://github.com/opencv/dldt/blob/2019/get-started-linux.md#configure-the-model-optimizer

But I had weird error about 'networkx'.  I did what github said and run script 'install_prerequisites_tf.sh', but still has error below:

python /home/jxiao/dldt/model-optimizer/mo_tf.py --input_model /home/jxiao/substation/keras-yolo3/model_data/ep036-loss21.932-val_loss16.520.pb --model_name trainedModel --input_shape [1,416,416,3]

 

Model Optimizer arguments:
Common parameters:
        - Path to the Input Model:      /home/jxiao/substation/keras-yolo3/model_data/ep036-loss21.932-val_loss16.520.pb
        - Path for generated IR:        /home/jxiao/dldt/model-optimizer/install_prerequisites/.
        - IR output name:       trainedModel
        - Log level:    ERROR
        - Batch:        Not specified, inherited from the model
        - Input layers:         Not specified, inherited from the model
        - Output layers:        Not specified, inherited from the model
        - Input shapes:         [1,416,416,3]
        - Mean values:  Not specified
        - Scale values:         Not specified
        - Scale factor:         Not specified
        - Precision of IR:      FP32
        - Enable fusing:        True
        - Enable grouped convolutions fusing:   True
        - Move mean values to preprocess section:       False
        - Reverse input channels:       False
TensorFlow specific parameters:
        - Input model in text protobuf format:  False
        - Path to model dump for TensorBoard:   None
        - List of shared libraries with TensorFlow custom layers implementation: None
        - Update the configuration file with input/output node names:   None
        - Use configuration file used to generate the model with Object Detection API:   None
        - Operations to offload:        None
        - Patterns to offload:  None
        - Use the config file:  None
Model Optimizer version:        unknown version
[ ERROR ]
Detected not satisfied dependencies:
        networkx: installed: 2.4, required: 2.4

Please install required versions of components or use install_prerequisites script
/home/jxiao/dldt/model-optimizer/install_prerequisites/install_prerequisites_tf.sh
Note that install_prerequisites scripts may install additional components.

 

It's very strange. Can anyone help me figure this out?
 

 

 

 

0 Kudos
1 Reply
Cary_P_Intel1
Employee
87 Views

Hi, Jun,

Are you able to run the "demo_security_barrier_camera.sh" demo under /opt/intel/openvino/deployment_tools/demo folder ? Please follow the instruction in "https://docs.openvinotoolkit.org/latest/_docs_install_guides_installing_openvino_linux.html" to check if you environment is right.

Reply