Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
62 Views

Protobuf error when use model optimizer

When I convert the caffemodel by use follow command, error is occured.

I used install prerequisities.bat and protobuf-3.5.1-py3.6-win-amd64.egg,  but error is not revised. What should I do ?

[command]

・mo.py --framework caffe --input_model ○○○.caffemodel --input_proto ○○○.prototxt --input_shape [1,3,300,300] --output_dir ○○○ --scale 1 --data_type FP32

[ ERROR ]
Detected not satisfied dependencies:
        protobuf: not installed, required: 3.5.1

Please install required versions of components or use install_prerequisites script
C:\Intel\computer_vision_sdk_2018.3.343\deployment_tools\model_optimizer\install_prerequisites\install_prerequisites_caffe.bat
Note that install_prerequisites scripts may install additional components.

0 Kudos
5 Replies
Highlighted
New Contributor I
62 Views

Upgrade protobuf 

pip install -U protobuf

which helps to resolve the issue

0 Kudos
Highlighted
62 Views

Hi Akihito,

Are you still facing the issue?

Kind Regards,

Monique Jones

0 Kudos
Highlighted
62 Views

Yes, I still facing the issue.

Could you tell me how to upgrade protobuf except for using openvino folder.

I used install_prerequisites_caffe.bat, and  protobuf-3.5.1-py3.6-win-amd64.egg, i don't know why protobuf doesn't upgrade.

0 Kudos
Highlighted
Employee
62 Views

Hope it's not too late. I had the same issue and resolved it by updating protobuf. I used anaconda package manager to install protobuf. 

# install the latest protobuf using anaconda package manager: conda install -c anaconda protobuf

Or if you don't use anaconda package, try this link: https://stackoverflow.com/questions/13616033/install-protocol-buffers-on-windows

(Not sure if this link works tho, cuz I'm working on Ubuntu.)

0 Kudos
Highlighted
62 Views

Thanks much. I solved thid problem.

0 Kudos