Community
cancel
Showing results for 
Search instead for 
Did you mean: 
94 Views

Python 2.7 bindings not working

hi,

 I have been experimenting with openvino's python bindings. The bindings for python 3 seem to be fine. However I have not been able to use python 2.7 with openvino. I get the following error when i try to run one of the samples. Other custom test scripts also throw the same error. They work with python 3 though. I ran the test on two machines one with python 2 and other python 3.

C:\Intel\computer_vision_sdk_2018.2.304\deployment_tools\inference_engine\samples\python_samples>python classification_sample.py -i "C:\Intel\computer_vision_sdk_2018.2.304\deployment_tools\demo\car.png" -m "C:\Intel\computer_vision_sdk_2018.2.304\deployment_tools\demo\ir\squeezenet1.1.xml" -d CPU >> out.txt

Traceback (most recent call last):
  File "classification_sample.py", line 79, in <module>
    sys.exit(main() or 0)
  File "classification_sample.py", line 67, in main
    exec_net = plugin.load(network=net)
  File "ie_api.pyx", line 169, in inference_engine.ie_api.IEPlugin.load
  File "ie_api.pyx", line 193, in inference_engine.ie_api.IEPlugin.load
  File "ie_api.pyx", line 298, in inference_engine.ie_api.BlobBuffer.to_numpy
  File "C:\Python27\lib\site-packages\numpy\core\numeric.py", line 501, in asarray
    return array(a, dtype, copy=False, order=order)
ValueError: 'order' is not a valid PEP 3118 buffer format string

 

Is it possible I have missed something during setup?

0 Kudos
1 Reply
Monique_J_Intel
Employee
94 Views

Hi Chandrakanth,

One of OpenVINO's requirements is to have Python 3.5 or higher so this is expected behavior with OpenVINO. To understand other pre-requisites for OpenVINO please visit https://software.intel.com/en-us/openvino-toolkit/choose-download/free-download-windows or https://software.intel.com/en-us/openvino-toolkit/choose-download/free-download-linux.

Kind Regards,

Monique Jones