Intel® Distribution of OpenVINO™ Toolkit
Community assistance about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all aspects of computer vision-related on Intel® platforms.

Rtsp Streaming using Nvr and Dvr



Goal : I want to use the rtsp streaming inside the openvino enviroment by using nvr and dvr

Hardware : I am using xeon workstation it has an processor of Intel® Xeon(R) CPU E5630

Operating system : Ubuntu 18.04.4

Gstreamer Version : 1.16.2

I have installed openvino by following the steps which was given in the link ( (

While using Dvr I have tried the following steps to access it in openvino environment

1.  dvr was connected to a wifi router and the camera used here is a wired camera , the another ethernet cable was connected to a pc from router

2: First the rtsp url was given in vlc media player to check the given url is able to get the streaming from dvr , it was able to get after that i gave it inside the openvino environment by accessing the dl streamer draw face attributes program it works well for the rtsp feed from the dvr

Now I am trying to use a nvr inside the openvino environment using rtsp

The nvr and the ipcamera both are connected to a wifi router and i am acessing that in pc via mobile usb tethering . In vlc the rtsp feed was sucessfull but while taking to an openvino enviroment i have faced some errors which are given below :

1.FIXME:default gstutils.c:3981:gst_pad_create_stream_id_internal:<fakesrc0:src> Creating random stream-id, consider implementing a deterministic way of creating a stream-id

2.ERROR from element udpsrc1: Internal data stream error

3.Debugging info: ../libs/gst/base/gstbasesrc.c(3072): gst_base_src_loop (): /GstPipeline:pipeline0/GstURISourceBin:urisourcebin0/GstRTSPSrc:source/GstUDPSrc:udpsrc1:
streaming stopped, reason not-linked (-1)

To solve these i have tired the following things

1. First i have used a gst debug to see what is the extact problem for this after that i have installed gstreamer tools libqt5 gstreamer1.0-libav etc but there is no change it

2. By changing the parameters inside the build and run sh by giving the url inside the brackets , using single and double quotes but no change

3.I have tried the overall update for the ubuntu to check is there any pending updates for gstreamer but was already uptodate for ubuntu 18.04

4.The sample url was given in gst-launch the preview window was opened but it show some glitches , and throwing an error decoder

Streaming URL Format

Rtsp Url For DVR :rtsp://

Rtsp Url For NVR :rtsp://

Please help me to solve the issue

0 Kudos
2 Replies

Hi Gomathy,

It seems more like a pipeline issue. I would suggest you try any of the following:

·      Reinstall and/or rebuild the latest version of GStreamer.

·      Add h264parse to the pipeline.

·      Try testing with a newer Intel processor. Intel Xeon E5630 is a first generation processor, whereas OpenVINO requires 6th to 10th generation Intel Core and Intel Xeon processors.



0 Kudos

Hi Gomathy,

This thread will no longer be monitored since we have provided suggestions. If you need any additional information from Intel, please submit a new question. 



0 Kudos