Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Abramov__Alexey
Beginner
102 Views

Running OpenVINO on older integrated GPUs

Jump to solution

I was trying to run an application with several models on integrated GPU of i3-4350T, but got following error:

Failed to create plugin /opt/intel/openvino/deployment_tools/inference_engine/lib/intel64/libclDNNPlugin.so for device GPU
Please, check your environment
[CLDNN ERROR]. clGetPlatformIDs error -1001

And clinfo returns:

./clinfo: Cannot get the number of OpenCL platforms available.

According to Product Specifications i3-4350T has HD Graphics 4600, which should be supported as stated here Supported Devices , but in my case, lspci prints following GPU:

Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

Are those CPUs/integrated GPUs officially supported for inference on GPU? And is there any limitation on generation (i.e. 4th generation is not supported, but 5th and newer are)?

Thanks in advance for help!

0 Kudos
1 Solution
Zulkifli_Intel
Moderator
82 Views

Hello Alexey Abramov,

 

This error means that OpenCL doesn't work for your device.

The problem is that the GPU driver has NEO compute runtime for OpenCL which supports only Gen8+ GPUs (Broadwell, Skylake, etc), but Intel(R) HD Graphics 4600 is Gen7 and below (Haswell). You can refer to this documentation for supported platforms:

 

https://github.com/intel/compute-runtime/blob/master/README.md#supported-platforms


Regards,

Zulkifli


View solution in original post

3 Replies
Zulkifli_Intel
Moderator
85 Views

Hello Alexey Abramov,


Thank you for your question.


We will look into this issue and get back to you with the information.


Regards,

Zulkifli


Zulkifli_Intel
Moderator
83 Views

Hello Alexey Abramov,

 

This error means that OpenCL doesn't work for your device.

The problem is that the GPU driver has NEO compute runtime for OpenCL which supports only Gen8+ GPUs (Broadwell, Skylake, etc), but Intel(R) HD Graphics 4600 is Gen7 and below (Haswell). You can refer to this documentation for supported platforms:

 

https://github.com/intel/compute-runtime/blob/master/README.md#supported-platforms


Regards,

Zulkifli


View solution in original post

Zulkifli_Intel
Moderator
49 Views

Hello Alexey Abramov,


This thread will no longer be monitored since we have provided information on the supported platform. If you need any additional information from Intel, please submit a new question.


Regards,

Zulkifli


Reply