Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
451 Views

Sample is not working using more than 5 SHAVE

I am trying to run example of inception_v3 from ncsdk/examples/tensorflow/inception_v3. By default the number of SHAVE (-s 4) is set as 4. I have successfully compiled and run the sample using make run. But when I tried to increase the number of SHAVE to 6 or 12, the sample was compiled successfully but throwing the following error while running.

 

E: [ 0] dispatcherEventReceive:235 dispatcherEventReceive() Read failed -1 E: [ 0] eventReader:253 Failed to receive event, the device may have reset E: [ 0] ncFifoReadElem:2735 Failed to read fifo element Traceback (most recent call last): File "./run.py", line 80, in <module> output, userobj = fifoOut.read_elem() File "/usr/local/lib/python3.5/dist-packages/mvnc/mvncapi.py", line 412, in read_elem raise Exception(Status(status)) Exception: Status.ERROR Makefile:53: recipe for target 'run' failed make: *** [run] Error 1

 

I am not able to figure out the reason for this. Please help me to fix the error.

Tags (1)
0 Kudos
4 Replies
idata
Community Manager
163 Views

@Akhilesh I would be glad to help you out. First of all, which version of the NCSDK are you using? I tried using the latest version of the NCSDK (2.08) and I had no issues compiling the model and running the model using make run specifying more than 4 SHAVEs in the MakeFile.

 

Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 FMA test -f graph || mvNCCompile -s 12 output/inception-v3.meta -in=input -on=InceptionV3/Predictions/Reshape_1 /usr/local/bin/ncsdk/Controllers/Parsers/TensorFlowParser/Convolution.py:44: SyntaxWarning: assertion is always true, perhaps remove parentheses? assert(False, "Layer type not supported by Convolution: " + obj.type) mvNCCompile v02.00, Copyright @ Intel Corporation 2017 /usr/local/lib/python3.5/dist-packages/tensorflow/python/util/tf_inspect.py:45: DeprecationWarning: inspect.getargspec() is deprecated, use inspect.signature() instead shape: (1, 299, 299, 3) res.shape: (1, 1, 1, 1001) TensorFlow output shape: (1, 1, 1001) Layer InceptionV3/InceptionV3/Mixed_5c/Branch_0/Conv2d_0a_1x1/Relu forced to im2col_v2, because its output is used in concat /usr/local/bin/ncsdk/Controllers/FileIO.py:65: UserWarning: You are using a large type. Consider reducing your data sizes for best performance Blob generated ./run.py Number of categories: 1001 Start download to NCS... /usr/local/lib/python3.5/dist-packages/mvnc/mvncapi.py:418: DeprecationWarning: The binary mode of fromstring is deprecated, as it behaves surprisingly on unicode inputs. Use frombuffer instead tensor = numpy.fromstring(tensor.raw, dtype=numpy.float32) ******************************************************************************* inception-v3 on NCS ******************************************************************************* 547 electric guitar 0.98828125 403 acoustic guitar 0.0075187683 715 pick, plectrum, plectron 0.0014801025 421 banjo 0.0009012222 820 stage 0.0006542206 ******************************************************************************* Finished
idata
Community Manager
163 Views

Thanks for the response @Tome_at_Intel , I am trying using the latest version of the NCSDK (2.08.01.02). I tried on x86 architecture I had no issues compiling the model and running the model using make run specifying more than 4 SHAVEs in the MakeFile. But now I am trying on TX2 and successfully compiled the sdk by following this link.

 

cp -r /opt/movidius/NCSDK/ncsdk-armv7l /opt/movidius/NCSDK/ncsdk-aarch64 sudo apt-get install libusb-1.0.0 cd <your NCSDK clone area> cd api/src make sudo make install cp /usr/local/lib/libmvnc.so.0 /opt/movidius/NCSDK/ncsdk-aarch64/api/c

 

But while running the example using make run, I am getting the following error:

 

$ make run test -f output/inception-v3.meta || ((wget http://download.tensorflow.org/models/inception_v3_2016_08_28.tar.gz && tar zxf inception_v3_2016_08_28.tar.gz && rm inception_v3_2016_08_28.tar.gz) && ./inception-v3.py) test -f graph || mvNCCompile --new-parser -s 12 output/inception-v3.meta -in=input -on=InceptionV3/Predictions/Reshape_1 /usr/local/lib/python3.5/dist-packages/scipy/_lib/_numpy_compat.py:10: DeprecationWarning: Importing from numpy.testing.nosetester is deprecated, import from numpy.testing instead. from numpy.testing.nosetester import import_nose /usr/local/lib/python3.5/dist-packages/scipy/stats/morestats.py:12: DeprecationWarning: Importing from numpy.testing.decorators is deprecated, import from numpy.testing instead. from numpy.testing.decorators import setastest /usr/local/bin/ncsdk/Controllers/Parsers/TensorFlowParser/Convolution.py:46: SyntaxWarning: assertion is always true, perhaps remove parentheses? assert(False, "Layer type not supported by Convolution: " + obj.type) /usr/local/bin/ncsdk/Controllers/Parsers/Phases.py:322: SyntaxWarning: assertion is always true, perhaps remove parentheses? assert(len(pred) == 1, "Slice not supported to have >1 predecessors") mvNCCompile v02.00, Copyright @ Intel Corporation 2017 ****** Info: No Weights provided. inferred path: output/inception-v3.data-00000-of-00001****** output/inception-v3.meta 2018-11-21 11:57:18.139888: E tensorflow/stream_executor/cuda/cuda_driver.cc:397] failed call to cuInit: CUDA_ERROR_NO_DEVICE 2018-11-21 11:57:18.140001: I tensorflow/stream_executor/cuda/cuda_diagnostics.cc:145] kernel driver does not appear to be running on this host (tegra-ubuntu): /proc/driver/nvidia/version does not exist output tensor shape (1, 1, 1, 1001) Fusing DeptwiseConv + Pointwise Convolution into plain Convolution Fusing Add and Batch after Convolution Fusing Pad and Convolution2D Fusing BatchNorm and Scale after Convolution Replacing BN with Bias&Scale Fusing Permute and Flatten Fusing Eltwise and Relu Eliminate layers that have been parsed as NoOp Evaluating input and weigths for each hw layer -------------------------------------- ---------------------- ---------------------- # Network Input tensors ['input:0#327'] # Network Output tensors ['InceptionV3/Predictions/Reshape_1:0#653'] Blob generated ./run.py Number of categories: 1001 Start download to NCS... Reading result E: [ 0] dispatcherEventReceive:235 dispatcherEventReceive() Read failed -1 E: [ 0] eventReader:253 Failed to receive event, the device may have reset E: [ 0] ncFifoReadElem:2735 Failed to read fifo element Traceback (most recent call last): File "./run.py", line 80, in <module> output, userobj = fifoOut.read_elem() File "/usr/local/lib/python3.5/dist-packages/mvnc/mvncapi.py", line 412, in read_elem raise Exception(Status(status)) Exception: Status.ERROR Makefile:53: recipe for target 'run' failed make: *** [run] Error 1
idata
Community Manager
163 Views

Hi @Tome_at_Intel !!! any update on this?

idata
Community Manager
163 Views

@Tome_at_Intel , Can you please tell me whether it is a hardware issue or software issue? I guess it's a hardware issue.

Reply