Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Alekseev__Dmitry
Beginner
115 Views

aocl program problem on Mustang-F100-A10

Hello,

 

I'm trying to run openvino samples on Mustang-F100-A10 under Ubuntu 16.04.5.

Im following this guide: https://software.intel.com/en-us/articles/OpenVINO-Install-Linux-FPGA

Evertything works fine on CPU, but doesn't work when it comes to running on FPGA.

My device is 01:00.0 Processing accelerators: Altera Corporation Device 2494 (rev 01)

My driver is aclpci_a10_1150_sg1_drv 

Driver information:

# modinfo aclpci_a10_1150_sg1_drv
filename:       /lib/modules/4.15.0-45-generic/misc/aclpci_a10_1150_sg1_drv.ko
license:        GPL
description:    Driver for Intel(R) OpenCL Acceleration Boards
author:         Dmitry Denisenko
srcversion:     39FF6377F73121FC2A3C88F
alias:          pci:v00001172d*sv00001172sd0000A1A1bc12sc*i01*
depends:
retpoline:      Y
name:           aclpci_a10_1150_sg1_drv
vermagic:       4.15.0-45-generic SMP mod_unload

aocl diagnose runs well:

aocl diagnose acl0
Using platform: Intel(R) FPGA SDK for OpenCL(TM)
Using Device with name: a10gx_1ddr : Intel Vision Accelerator Design with Intel Arria 10 FPGA (acla10_1150_sg10)
Using Device from vendor: Intel(R) Corporation
clGetDeviceInfo CL_DEVICE_GLOBAL_MEM_SIZE = 4294967296
clGetDeviceInfo CL_DEVICE_MAX_MEM_ALLOC_SIZE = 4293918720
Memory consumed for internal use = 1048576
Actual maximum buffer size = 4293918720 bytes
Writing 4095 MB to global memory ...
Allocated 1073741824 Bytes host buffer for large transfers
Write speed: 3108.20 MB/s [3079.53 -> 3143.87]
Reading and verifying 4095 MB from global memory ...
Read speed: 2926.63 MB/s [2909.77 -> 2957.50]
Successfully wrote and readback 4095 MB buffer

...

But when I try to program memory via pcie it compains it can't write:

# aocl program acl0 /opt/intel/computer_vision_sdk/bitstreams/a10_vision_design_bitstreams/5-0_PL1_FP11_SqueezeNet.aocx
aocl program: Running program from /opt/altera/aocl-pro-rte/aclrte-linux64/board/hddlf_1150_sg1/linux64/libexec

Programming device: a10gx_1ddr : Intel Vision Accelerator Design with Intel Arria 10 FPGA (acla10_1150_sg10)
Reprogramming device [0] with handle 1
MMD INFO : [acla10_1150_sg10] PR base and import compile IDs do not match
MMD INFO : [acla10_1150_sg10] PR base ID currently configured is 0x25e14e25
MMD INFO : [acla10_1150_sg10] PR import compile expects ID to be 0x389dd9fe
MMD INFO : [acla10_1150_sg10] Falling back to JTAG programming instead of PR
sh: 1: quartus_stp: not found
MMD INFO : Autodetect Cable not found!!
MMD INFO : setting Cable to default value 1
MMD INFO : setting Device Index to default value 1
MMD INFO : executing "quartus_pgm -c 1 -m jtag -o "P;reprogram_temp.sof@1""
sh: 1: quartus_pgm: not found
sh: 1: quartus_pgm: not found
sh: 1: quartus_pgm: not found
mmd program_device:  Board reprogram failed
  OpenCL Notification Callback: Reprogram of device failed
Failed clCreateProgramWithBinary.
Error code: -2
aocl program: Program failed.

 

Could you please point me what I am doing wrong?

I tried reinstalling everything including driver, but no luck.

Dmitry

 

 

 

 

0 Kudos
1 Reply
Alekseev__Dmitry
Beginner
115 Views

Solved the problem by installing openvino SDK version 2018.4 instead of 2018.5.1

Reply