Intel® Edge Software Hub
Get answers from community peers to your questions about building Edge Software Hub solutions for edge compute node.
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
420 Discussions

[EI4AMR] Confirmation the mapping slip

Arioka
Novice
608 Views

Dear Customer Support,

 

I verify AMR SDK with AAEON* Robot Kit.

When I create the map following to Section "Control the UP Xtreme i11 Robotic Kit Using a Gamepad" in following website, it’s not working mapping correctly.

Launch Wandering Application on AAEON* Robot Kit (intel.com)

AMR.PNG

 

We were testing in a square environment, however the map slips gradually.
Could you please suggest/operation if you have any information.

 

Best Regards,

Arioka

0 Kudos
1 Solution
Arioka
Novice
545 Views

Hi Jesus-san,

 

I re-confirmed calibration. It seems that we don't calibrate well.

This issue is resolved by calibration.

 

Thank you for your support.

 

Best Regards,

Arioka

View solution in original post

0 Kudos
4 Replies
JesusE_Intel
Moderator
577 Views

Hi Arioka,


Thanks for reaching out, could you please help answer the following questions?

  • What version of Edge Insights for AMR are you using?
  • Did you run into any issues when calibrating your robots IMU sensor?
  • Is the robot moving properly?
  • Are the map results the same when moving the robot with Wandering App or using a gamepad?


Regards,

Jesus


0 Kudos
Arioka
Novice
564 Views

Hi Jesus-san,

 

Thank you for your support.

  • What version of Edge Insights for AMR are you using?

-> I use EI for AMR ver.2022.2.

  • Did you run into any issues when calibrating your robots IMU sensor?

-> I don't face any issue during calibrating. However, I couldn't judge whether I can calibrate correctly because I face this issue every time.

  • Is the robot moving properly?

-> Yes. I tried "wandering", "operation by keyboard" and "operation by Game Pad". Robot can move correctly but the mapping is not working correctly.

  • Are the map results the same when moving the robot with Wandering App or using a gamepad?

-> Yes. The mapping can operate correctly only about first 1 minute. If the mapping continues, the mapping slips gradually like as picture.

 

Best Regards,

Arioka

0 Kudos
Arioka
Novice
546 Views

Hi Jesus-san,

 

I re-confirmed calibration. It seems that we don't calibrate well.

This issue is resolved by calibration.

 

Thank you for your support.

 

Best Regards,

Arioka

0 Kudos
JesusE_Intel
Moderator
533 Views

Hi Arioka,


Glad you were able to resolve your issue! If you need any additional information, please submit a new question as this thread will no longer be monitored.


Regards,

Jesus


0 Kudos
Reply