Intel® Edge Software Hub
Get answers from community peers to your questions about building Edge Software Hub solutions for edge compute node.
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
361 Discussions

ERROR: Service 'tls_apiui' failed to build

HuynhVanThuan
New Contributor I
623 Views

Hi,

I'm having problems installing TLS when I executed the "./setup_TLS_docker.sh" command but systems gives me the following error message:

'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

/bin/sh: 1: npm: not found

ERROR: Service 'tls_apiui' failed to build: The command '/bin/sh -c npm install serve' returned a non-zero code: 127

'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

I don't understand the problem I'm having. Can you help me?

I am using Ubuntu OS version 18.04.06

 

Regard,

Huynh

Labels (1)
0 Kudos
1 Solution
HuynhVanThuan
New Contributor I
546 Views

Hi JeusE,

 

I'm not sure about the error I got but somehow it didn't give the same error when I was installing on another computer with the same version installed

 

Regard,

Huynh

View solution in original post

0 Kudos
5 Replies
JesusE_Intel
Moderator
597 Views

Hi Huynh,


I just installed Edge Insights for Industrial 2.6.3 and ran setup_TLS_docker.sh without any issues. Could you please check your internet connection and re-run the script?


Regards,

Jesus


0 Kudos
HuynhVanThuan
New Contributor I
585 Views

Hi JesusE,

 

i used to get this error but it solved when i upgrade Ubuntu OS to 20.04 version but i get this problem every time i use 18.04.06 version. I want to go back to version 18.04.xx because it is the recommended Ubuntu OS according to the manual. So can I know the exact OS you are using? I think some version you are using in 18.04.xx will solve my problem.

 

Regard,

Huynh

 

 

0 Kudos
JesusE_Intel
Moderator
579 Views

Hi Huynh,


I am using Ubuntu 18.04.1. However, the system requirements lists Ubuntu 18.04.3 LTS. Let me install the LTS version and confirm it's working as well.


Regards,

Jesus


0 Kudos
HuynhVanThuan
New Contributor I
547 Views

Hi JeusE,

 

I'm not sure about the error I got but somehow it didn't give the same error when I was installing on another computer with the same version installed

 

Regard,

Huynh

0 Kudos
JesusE_Intel
Moderator
526 Views

Thank you for confirming. If you need any additional information, please submit a new question as this thread will no longer be monitored.


0 Kudos
Reply