Intel® Edge Software Hub
Get answers from community peers to your questions about building Edge Software Hub solutions for edge compute node.
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
395 Discussions

Newly created virtual IP is giving error


While installing castle lake server, in a step, we need to provide virtual address of load balancer, which is unused. We have created virtual IP and tried to follow this step but we are getting below error. 

dev@dev-NUC8i3BEH:~/edge_insights_industrial/Edge_Insights_for_Industrial_2.3.2/orchestrator/orchestrator/server-package$ cd ..
dev@dev-NUC8i3BEH:~/edge_insights_industrial/Edge_Insights_for_Industrial_2.3.2/orchestrator/orchestrator$ sudo swapoff -a
[sudo] password for dev: 
dev@dev-NUC8i3BEH:~/edge_insights_industrial/Edge_Insights_for_Industrial_2.3.2/orchestrator/orchestrator$ sudo sysctl -w net.ipv4.ip_nonlocal_bind=1
net.ipv4.ip_nonlocal_bind = 1
dev@dev-NUC8i3BEH:~/edge_insights_industrial/Edge_Insights_for_Industrial_2.3.2/orchestrator/orchestrator$ cd server-package/
dev@dev-NUC8i3BEH:~/edge_insights_industrial/Edge_Insights_for_Industrial_2.3.2/orchestrator/orchestrator/server-package$ curl -u admin >
Enter host password for user 'admin':
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 58350    0 58350    0     0   159k      0 --:--:-- --:--:-- --:--:--  159k
dev@dev-NUC8i3BEH:~/edge_insights_industrial/Edge_Insights_for_Industrial_2.3.2/orchestrator/orchestrator/server-package$     chmod +x
dev@dev-NUC8i3BEH:~/edge_insights_industrial/Edge_Insights_for_Industrial_2.3.2/orchestrator/orchestrator/server-package$ /bin/bash
*** [Start] Bootstrap CSL Server Version 1.5.3483-a0f1d8e9 ***
{INFO}: Running on ubuntu 18.04
Docker daemon configuration is correctly set.
Network interfaces available:
| ID   | NAME                 | IP                         |
| 1    | wlp0s20f3            |                |
| 2    | wlp0s20f3            |               |
| 3    | br-07787c332062      |                 |
| 4    | docker0              |                 |
Please enter the network interface ID to be used for CSL: 1
{INFO}: Using Network Interface=wlp0s20f3, IP Address=
Please enter the virtual IP to be used for load balancer:
Checking validity of ...
{ERR}: is already in use!
Please enter the virtual IP to be used for load balancer: 

 We tried multiple times to create virtual IP and give here but same error. 

Request you to provide input on this.

Labels (1)
0 Kudos
1 Reply

Hi @Snehal_Yesugade 

The Virtual IP that needs to be key in should be the unused IP within the same subnet, seems like the Virtual IP that you key in have been assigned to another machine. 

May I know how you created your Virtual IP? you will only need to check for the IP availability without assigning it to anywhere yet until you run the script. 

0 Kudos