Intel® Edge Software Hub
Get help on building Edge Software Hub solutions for edge compute node
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

See our new article on Fidelity-first Ray Tracing in the Heterogeneous Compute Era.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
200 Discussions

Temporary volumes error while uploading csl_app_spec file in csl manager dashboard in eis 2.3.3

Smrithi
New Contributor I
527 Views

I am trying to upload the csl_app_spec.json file in the csl manager dashboard UI, but it gives me an error saying: Invalid temporary volumes path detected. I have given only valid temporary volumes in all the module spec files, but still I am geting the same error. I am currently using eis version 2.3.3 , and it seems there are only 3 valid temporary paths that are available. I have attached the SS of the error. Kindly help.

Labels (1)
0 Kudos
1 Solution
WengWai_C_Intel
Moderator
438 Views

@Smrithi 

From the application.properties screenshot you shared, it seem there is a line space issue for the "whitelisted_mounts" configuration. After the "/tmp/.X11-" it jump to the next line. You should have all the mounted volume path separated by comma, no line spacing required. Pls refer to the sample in the screenshot I've shared below. 

After fix the line spacing issue, pls restart the CSL manager container and redeploy using the original module spec files configuration with Temporary Volumes.

WengWai_C_Intel_0-1609811306461.png

 

View solution in original post

9 Replies
Smrithi
New Contributor I
513 Views

I have removed the temporary volumes from all the module spec files individually also and then deployed the csl_app_spec.json. At that time the above mentioned error was not there, but all the container's status were shown as pending and they were not running at all.

Smrithi
New Contributor I
494 Views

I am waiting for a reply on this issue as it has not been resolved yet.

WengWai_C_Intel
Moderator
482 Views

@Smrithi 

Can you share and elaborate further on the following?

1) What changes have been made to the module spec files and what are the setup changes since the previous working setup?

2) After removing the temporary volumes from module spec files, have you updated the module spec files into SMR by  removing the old ones and replacing with new module spec files?

3) Can you share the following files for checking?

     a) csl_app_spec file

     b) All module spec files

     c) application.properties file from  /opt/csl/csl-manager/ directory in the CSL manager system

thanks.

Smrithi
New Contributor I
475 Views

I have installed csl client in a new server setup and the version is 2.3.3. The error I am facing is on this system, while uploading the csl_app_spec.json file. After removing the temporary volumes from module spec files, I have updated the module spec files into SMR by removing the old ones and replacing with new module spec files using csladm and verified the same. After removing the invalid temporary volumes path, the mentioned error was not there, but the modules never run and are shown as pending after uploading csl_app_spec.json in csl manager dashboard. I have attached all the files as mentioned.

WengWai_C_Intel
Moderator
467 Views

@Smrithi 

From the previous first question, can you help to point out which module spec file you have modified with Temporary volumes from the original default setup, and what modification did you made? It will be good to share with us on that, as the module spec files you have provided are just the same as the default. This might help us to check what modification being done earlier that can cause any issue.

Smrithi
New Contributor I
460 Views

I have attached the files that have been modified. I have removed the invalid temporary paths as only 3 paths are mentioned as valid in the error message displayed in csl manager UI :-/dev, /var/tmp, /tmp/.X11- is allowed in the cluster. But in visualizer if I keep /tmp/.X11-unix:/tmp/.X11-unix it again gives the error saying invalid path. But if I keep it as empty the modules donot run after uploading the csl_app_spec.json.

WengWai_C_Intel
Moderator
451 Views

@Smrithi 

Removing the default Temporary volumes in the module spec files should not be necessary and it is not good idea too because some of the container will need to access those directory for data storage e.g ImageStore. During the CSL manager setup, all the Temporary volume will be added under "whitelisted_mounts" as you updated in the application.properties file. So, the question is, have you restarted CSL mgr container to make it take effect? Can you restart your CSL mgr container, and then use the original module spec files (with default Temporary Volumes) register in SMR to deploy the containers again using csl_app_spec file through the CSL mgr web UI?

Smrithi
New Contributor I
444 Views

As suggested I restarted the csl manager container and tried to deploy the containers. It's still showing the same error as previously mentioned.

WengWai_C_Intel
Moderator
439 Views

@Smrithi 

From the application.properties screenshot you shared, it seem there is a line space issue for the "whitelisted_mounts" configuration. After the "/tmp/.X11-" it jump to the next line. You should have all the mounted volume path separated by comma, no line spacing required. Pls refer to the sample in the screenshot I've shared below. 

After fix the line spacing issue, pls restart the CSL manager container and redeploy using the original module spec files configuration with Temporary Volumes.

WengWai_C_Intel_0-1609811306461.png

 

View solution in original post

Reply