Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
808 Discussions

Quartus Prime Standard 20.4 silent installation with SCCM

ThomasH
Beginner
3,055 Views

When deploying Intel FPGA 20.4 standard we run into an issue when attempting to install the software as required. The install will just hang up with no error message while running the Quartus installer. When we set the deployment to available it is able to successfully install.

Install commands
QuartusSetup-20.1.1.720-windows.exe --mode unattended --unattendedmodeui none --installdir C:/intelFPGA/20.1 --accept_eula 1

We saw that this issue was also reported in 19.1, but it doesn't look like a resolution was found.
https://community.intel.com/t5/Intel-FPGA-Software-Installation/Quartus-Prime-Standard-19-1-silent-i...

Any recommendations would be greatly appreciated.

0 Kudos
1 Solution
DougBarry
Beginner
2,080 Views

Hi Thomas,

 

I've spent 2 months fighting this myself and had a breakthrough. It seems that the Quartus installer uses 'Bitrock', and installer technology I have also been fighting when trying to install Microchip's MPLAB X IDE 5.5.

 

Long story short, this forum post helped: https://docs.microsoft.com/en-us/answers/questions/397336/different-behaviour-required-vs-available-...

 

Use the checkbox on the Programs tab of the Deployment Type, to 'Run installation and uninstallation as 32bit on 64 bit clients'. Once I ticked that, my script actually managed to install quartus on a couple of machines last night.

 

I've written a long winded powershell script that pre-installs the usb blaster drivers (and puts their certs in machine trusted), installs quartus, then modelsim, then the patch for 20.1, and finally does the firewall entries for the right bits.

 

The command line that now works as 32 bit process is:

...

23/09/2021 05:43:43 Started Step2 Install
Executing 'C:\WINDOWS\ccmcache\36\app\QuartusSetup-20.1.1.720-windows.exe --mode unattended --unattendedmodeui none --installdir "C:\Program Files\IntelQuartusV20" --accept_eula 1' at 23/09/2021 05:43:43
23/09/2021 05:49:35 finished Step2 Install

...

 

Have a go with that, hope it helps. It's been driving me up the wall for years since Intel took this over.

 

Doug.

View solution in original post

37 Replies
RichardTanSY_Intel
2,295 Views

Hi @ThomasH 

From the link provided:

Have you try to run the installer with: --skip_registration 1
This will skip installing some prerequisites, adding some registry entries.
Let me know whether the installation succeed.

If not, try running it with: --syncdebugtrace debug.txt
then pass us the debug.txt file. I'll ask the engineer to approach the vendor for further investigate. 

Have you try to turn off all antivirus software and try to install again? Just to be sure that we rule out this possibility. 

Also, could you help to describe what do you mean by "When we set the deployment to available it is able to successfully install." ? 

Can you help to attach a screenshot of the issue where the install just hang up with no error message  as well?

Thanks.

 

Best Regards,

Richard Tan

 

ThomasH
Beginner
2,285 Views

Thanks for the quick response,
We attempted to run the install with "--skip_registration 1" without any luck. I have attached is the debug log that was generated.
--Also, could you help to describe what do you mean by "When we set the deployment to available it is able to successfully install." ? 
in SCCM you can set a deployment to required (it will install automatically) or available (the install can be started by the user)

I've attached a screenshot of what we see, the quartus installer is running in the background and is using CPU and memory but there is no disk usage. We let that run for a couple hours without any change.

RichardTanSY_Intel
2,254 Views

Hi @ThomasH 

 

Can you try a smaller size installer to see if it installs successfully? A good one to try is the Quartus Prime Pro Edition Help installer.

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

ThomasH
Beginner
2,237 Views

Sorry for the delay, we tried just the helper tool but ran into the same issue.

RichardTanSY_Intel
2,218 Views

Hi @ThomasH 

 

We have ask the vendor to check on this and this may takes some time. 

I will update once there is any finding. 

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

RichardTanSY_Intel
2,178 Views

Hi @ThomasH 

 

Could you try running the installer with --parallel-decompression-cores 1?

 

QuartusSetup-20.1.1.720-windows.exe --mode unattended --unattendedmodeui none --installdir C:/intelFPGA/20.1 --accept_eula 1 --parallel-decompression-cores 1 --syncdebugtrace debug-1-core.txt


And send us the resulting debug.txt file?

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

ThomasH
Beginner
2,169 Views

Sure thing, attached is the log file.

RichardTanSY_Intel
2,164 Views

Hi @ThomasH 

 

May I know which Windows version that you are using?

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

ThomasH
Beginner
2,135 Views

Win 10 Version 21H1 (OS Build 19043.1052)

RichardTanSY_Intel
2,056 Views

Hi @ThomasH 

 

I sent 'debug-1-core.txt' to the vendor, but they found it was not the one generated by the updated installer. Could you help to double check? You will need to run:

QuartusHelpSetup-20.1.1.720-windows.exe --mode unattended --unattendedmodeui none --installdir C:/intelFPGA/20.1 --accept_eula 1 --parallel-decompression-cores 1 --syncdebugtrace debug-1-core.txt

within SCCM, send us back the debug output file: debug-1-core.txt

 

Below is the reply from vendor:

The installer you shared seems correct (it includes the debug and is built with the provided InstallBuilder version) but the debug file sent by your customer does not match.

We see the uploaded installer is named: QuartusHelpSetup-20.1.1.720-windows.exe while the debug file from your user seems to correspond to QuartusSetup-20.1.1.720-windows.exe. Apart from the difference in the name, we see it seems to be much bigger. In addition, recent versions of InstallBuilder include the version string from the used builder in the debug file, which does not appear in your customer debug file, so it seems they did not use the latest installer to recreate the debug file. Could you ask them to verify if that is the case? You could suggest invoking the installer first with --version to confirm the builder matches.

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

RichardTanSY_Intel
2,017 Views

Hi @ThomasH 

 

I sent 'debug-1-core.txt' to the vendor, but they found it was not the one generated by the updated installer. Could you help to double check? You will need to run:

QuartusHelpSetup-20.1.1.720-windows.exe --mode unattended --unattendedmodeui none --installdir C:/intelFPGA/20.1 --accept_eula 1 --parallel-decompression-cores 1 --syncdebugtrace debug-1-core.txt

within SCCM, send us back the debug output file: debug-1-core.txt

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

ThomasH
Beginner
1,995 Views

Sorry for the mistake. I have attached the new log, thanks for looking into this.

RichardTanSY_Intel
1,981 Views

Hi @ThomasH 

 

Did the installer hang this time? According to the debug file, it was completed. Could you share us the installation log if you still have it?

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

RichardTanSY_Intel
1,939 Views

Hi @ThomasH 

 

Did the installer hang this time? According to the debug file, it was completed. Could you share us the installation log if you still have it?

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

RichardTanSY_Intel
1,840 Views

Hi @ThomasH 

 

Did the installer hang this time? According to the debug file, it was completed. Could you share us the installation log if you still have it?

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

ThomasH
Beginner
1,789 Views

I'm sorry for the delay, we've had some other issues that have taken precedence. It did fail to install, attached is the requested install log. Thank you for your help and patience.

RichardTanSY_Intel
1,735 Views

Hi @ThomasH 

 

I don't think the debug-1-core.txt file that you provided is the one that we need.

The installation log files are in <installdir>/logs directory. They should be in text files. 

Could you help to confirm this and send us the installation log? 

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

ThomasH
Beginner
1,631 Views

The only log I found is quartus_help-20.1.1.720-windows-install.log, located in C:\intelFPGA\20.1\logs and contains the following

 

Log started 09/15/2021 at 01:40:47
Preferred installation mode : unattended
Trying to init installer in mode unattended
Mode unattended successfully initialized
Preparing to Install
Preparing to Install
Unpacking files
Installation completed
Log finished 09/15/2021 at 02:16:39
Exiting with code 0

RichardTanSY_Intel
1,584 Views

Hi @ThomasH 

 

It seems to me that the installation was completed. 

Could you help to check whether it was installed? 

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

ThomasH
Beginner
1,569 Views
Reply