Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
802 Discussions

The system only recognizes the FPGA for a couple of minutes!!!!

MEghb
Beginner
351 Views

I installed the new Intel PAC on my workstation recently and I installed the software stack and opencl on my system to use the board. However, the systems only recognizes the board for a couple of minutes and I can run sample examples on they work fine. However, after around 5 minutes of fpga inactivity the system cannot recognize the baord anymore through "aocl diagnose". And the only solution I found so far it to power off the machine and start it again, which is not a feasible solution for me anymore.

Here are the result of "aocl diagnose" just couple of minutes apart.

before.png file is the screenshot right after start up and after.png is 5 minutes after that without making any changes.

Also, I am using Ubuntu 18.04 on my workstation.

I appreciate it if anybody could help me with that.

 

Thanks,

Mostafa

 

0 Kudos
4 Replies
AnilErinch_A_Intel
236 Views

Hi,

Please let us know the details

  1. Is the fpgainfo fme available
  2. Can you check whether the temperature is rising during this 5 minutes of inactivity . Like running the aocl diagnose in brief intervals and letting know the results to us.
  3. Can you increase the fan speed and check whether this is affecting the performance.

Regards

Anil

 

MEghb
Beginner
236 Views

Hi,

Thanks for your response. You were right. I checked the temp as you suggested and it seems like the system is not cooling the FPGA well. I increased my fan speed in order the cool the FPGA, and it is working well after that. I checked the temperature regularly and it was not increasing like before. Do you think it could be harmful to the system since I need to keep the fans running at a higher speed than normal use?

 

Regards,

Mostafa

AnilErinch_A_Intel
236 Views

Hi

While it is not uncommon to increase the fan speed, we would advise to check with the workstation vendor to know the pros ,cons and limits of workstation fan speed increase.

Regards

Anil

MEghb
Beginner
236 Views

Thanks, you are right. I should check that.

 

Mostafa,

 

Reply