Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
741 Views

USB Blaster device is not recognized by Quartus Programmer

Using Quartus II 32-bit ver 12.0 on Windows 7.

I believe I have installed the usb blaster driver correctly, USB-Blaster displays correctly under Control Panel>Devices and Printers.

But usb blaster is not available on Quartus Programmer, nor is it available to Add Hardware.

 

Please help!

8 Replies
Highlighted
Employee
95 Views

Hi ,

I believe that, you could have checked this, but just to ensure that "Currently selected hardware" drop-down menu as attached,

Please refer the below KDB link & let me know how it works in this case,

https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/soluti...

hwd.jpg

Regards,

Vikas

0 Kudos
Highlighted
Novice
95 Views

Thanks Vikas

 

To clarify, the Programmer shows No Hardware selected. In the Hardware Setup, the Currently Selected Hardware shows No Hardware, as you attached, and there is no USB blaster option in the drop down menu, as you showed. There is also no USB blaster (or anything) under the Available Hardware Options.

 

I did check the KBS page you suggested, but I do not see any Altera JTAG Server running on my system services

 

Is there something else that I can do to fix this issue?

0 Kudos
Highlighted
Novice
95 Views

I have also attempted to use this solution, where a user with the same issue uninstalled and reinstalled the software and driver and ran the program as admin. But for me, the issue persists :(

0 Kudos
Highlighted
Employee
95 Views

Hi,

Please check the below things once again,

  1. Ensure that USB Blaster Adapter connected to the board in correct manner(one to one mapping)
  2. Check with the same USB Blaster with another system
  3. If possible try with another USB Blaster with same system.

Regards,

Vikas

0 Kudos
Highlighted
Novice
95 Views

Vicky,

 

I have tried the USB blaster device (Altera board) with another system and it was successful.

However, using the same device on my own system, the issue persists with no change!

 

I do not currently have access to another usb device.

However I feel that the issue is with my system/configuration as the device works with another computer.

 

Please help, what else can i do to fix this issue?

0 Kudos
Highlighted
Employee
95 Views

Hi,

It may be because of Quartus II software version 12.0 SP1 issue on the current system, you can check by downloading and installing Patch 1.07 fro windows from link below,

https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/soluti...

or else check by downloading and installing 12.0sp2_quartus_windows.exe from link below,

https://www.intel.com/content/www/us/en/programmable/downloads/software/quartus-ii-se/120.html

 

I would like to recommend you,try to use latest version of Quartus(18.1).

Thanks,

Vikas

 

0 Kudos
Highlighted
Novice
95 Views

I am using the Web Edition of Quartus and an Altera FPGA with Cyclone II.

Newer versions of Quartus (18.1) no longer support Cyclone II in the Web Edition so I am using an older version.

 

I currently have Quartus version 12.0 installed with no service pack.

Would it be preferable to install 12.1, 12.0 with the SP2, or the SP1 and the patch?

0 Kudos
Highlighted
Employee
95 Views

Hi,

I would recommend the Quartus II software version 12.0 SP2.

 

Thanks,

Vikas

0 Kudos