Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.
911 Discussions

Unable to get Questa-Intel FPGA starter edition license working in Ubuntu

EkanshBhatnagar
Beginner
644 Views

Hi, 

My problem:

ekansh@ekansh-Y540-15IRH-PG0:~/intelFPGA_lite/21.1/questa_fse/bin$ ./vsim
Unable to checkout a license. Make sure your license file environment variable (e.g., LM_LICENSE_FILE)
is set correctly and then run 'lmutil lmdiag' to diagnose the problem.
Unable to checkout a license. Vsim is closing.
** Error: Invalid license environment. Application closing.

What I have already done:

- Got my license in the mail.

- set my LM_LICENSE_FILE variable using

 export LM_LICENSE_FILE="<my-path-to-email-license-file>"  in .bashrc

- restarted my computer/ also tried to source .bashrc.

- tried lmgrd, got this

ekansh@ekansh-Y540-15IRH-PG0:~/intelFPGA_lite/21.1/questa_fse/linux_x86_64$ 16:52:20 (lmgrd) Can't make directory /usr/tmp/.flexlm, errno: 2(No such file or directory)
16:52:20 (lmgrd) license manager: can't initialize:No SERVER lines in license file.
16:52:20 (lmgrd) License Path: "/home/ekansh/intelFPGA_lite/21.1/questa_fse/license.dat"
16:52:20 (lmgrd) FlexNet Licensing error:-13,66

 

Labels (1)
0 Kudos
2 Replies
AR_A_Intel
Employee
630 Views

Hello

Good day

 

Welcome to INTEL forum. But before setting up your license, would you kindly help check whether your machine is supported or not (OS) by referring to link below:

https://www.altera.com/support/support-resources/download/os-support.html


AR_A_Intel
Employee
593 Views

We do not receive any response from you to the previous reply that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you


Reply