Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CARAM
Beginner
619 Views

Intel Fpga Monitor Program not open Editor Window tool

 

I are doing the "intel fpga monitor program tutorial for ARM" for Quartus Prime 17.1

I have downloaded and installed the intel_fpga_upds_setup_v17.tar archive and quartus ii 17.1 suite.

My operating system is ubuntu 18.04 LTS

When i run the intel-fpga-monitor program in the Menu bar the windows menu have the Editor and Program Files menus with GREY CHARS.

When i do the simple.s tutorial with DE1-SoC-computer system i can edit the source assembly module simple.s

How can i do for correct install the monitor program? Again download the installer archive? Some setting up?

Thanks in advance

 

0 Kudos
8 Replies
234 Views

Hi,

 

Can you screenshot the bugged menus that you see?

 

Also, have you follow thoroughly the steps to install when using Linux operating system at section 2.2 Using a Linux Operating System?

CARAM
Beginner
234 Views

Hi,

I have installed intel_fpga_upds_setup with the oficial instructions but i think that the system configuration of Ubuntu 18.04 (java virtual machine, jar compiler, etc) are not correct. These are the warning when i execute ./intel-fpga-monitor-program script:

University_Program/Monitor_Program/bin$ ./intel-fpga-monitor-program

Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library /home/candido/flexdock/RubberBand.so which might have disabled stack guard. The VM will try to fix the stack guard now.

It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.

java.net.ConnectException: Conexión rehusada

   at java.net.PlainSocketImpl.socketConnect(Native Method)

   at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)

   at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)

   at java.net.AbstractPlainSocketImpl.connect(Unknown Source)

   at java.net.SocksSocketImpl.connect(Unknown Source)

   at java.net.Socket.connect(Unknown Source)

   at java.net.Socket.connect(Unknown Source)

   at java.net.Socket.<init>(Unknown Source)

   at java.net.Socket.<init>(Unknown Source)

   at org.flexdock.docking.drag.outline.x11.Connection.<init>(Connection.java:35)

   at org.flexdock.docking.drag.outline.x11.Graphics.create(Graphics.java:49)

   at org.flexdock.docking.drag.outline.x11.Graphics.<clinit>(Graphics.java:34)

   at org.flexdock.docking.drag.outline.x11.X11RubberBand.<clinit>(X11RubberBand.java:14)

   at java.lang.Class.forName0(Native Method)

   at java.lang.Class.forName(Unknown Source)

   at org.flexdock.util.Utilities.createInstance(Utilities.java:285)

   at org.flexdock.docking.drag.effects.EffectsManager.createRubberBand(EffectsManager.java:94)

   at org.flexdock.docking.drag.effects.EffectsManager.loadSystemRubberband(EffectsManager.java:137)

   at org.flexdock.docking.drag.effects.EffectsManager.prime(EffectsManager.java:43)

   at org.flexdock.docking.drag.effects.EffectsManager.<clinit>(EffectsManager.java:37)

   at org.flexdock.docking.drag.DragManager.prime(DragManager.java:42)

   at org.flexdock.docking.DockingManager.init(DockingManager.java:137)

   at org.flexdock.docking.DockingManager.<clinit>(DockingManager.java:127)

   at monitor.ui.UIManager.initDocking(UIManager.java:338)

   at monitor.ui.UIManager.init(UIManager.java:161)

   at monitor.globals.Globals.init(Globals.java:84)

   at monitor.Main.main(Main.java:38)

There is a warning because Rubberband.so is 32 bit library and de Java VM is 64 bit

I have attach the image of the interfaz with "Editor" and " Projects Files" menus not accesible.

Thanks

Cándido

CARAM
Beginner
234 Views

Hi , there are some menu option that can the effect of activate editor "Edit -> Enable Source Level Debugging" and "Edit -> Extended -> Debug Info". Sometimes if it activate these options after Board connection and configuration the "Editor" and " Project Files". Kind Regards.

234 Views

Hi,

 

From your latest reply, are you still seeing the "Editor" and "Project Files" tab un-clickable?

CARAM
Beginner
234 Views

Hi,

No problem if i select first "Enable Source Level Debugging"

Thanks

234 Views

Hi,

 

Noted the information, are you facing any other issue in the tutorial?

CARAM
Beginner
234 Views

Thanks! not at moment

234 Views

Hi,

 

Cool! If you have other question, don't hesitate to post a new questions.

 

Thanks.

Reply