Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
1171 Discussions

VWF Simulation error with Quartus Prime 20.1

SSchneider
Beginner
913 Views

I fixed my first error message by manually removing the "vsim -novopt -c -t 1ps -L ..." line, however, now I am getting the generic error message below.  Any thoughts?  Thanks in advance for any suggestions..

# do Full_Adder.do

# ** Warning: (vlib-34) Library already exists at "work".

# Model Technology ModelSim - Intel FPGA Edition vlog 2020.1 Compiler 2020.02 Feb 28 2020
# Start time: 13:03:12 on Sep 21,2020
# vlog -work work Full_Adder.vo
# -- Compiling module Full_Adder
#
# Top level modules:
# Full_Adder
# End time: 13:03:12 on Sep 21,2020, Elapsed time: 0:00:00
# Errors: 0, Warnings: 0

# Model Technology ModelSim - Intel FPGA Edition vlog 2020.1 Compiler 2020.02 Feb 28 2020
# Start time: 13:03:12 on Sep 21,2020
# vlog -work work Waveform1.vwf.vt
# -- Compiling module Full_Adder_vlg_vec_tst
#
# Top level modules:
# Full_Adder_vlg_vec_tst
# End time: 13:03:12 on Sep 21,2020, Elapsed time: 0:00:00
# Errors: 0, Warnings: 0
# Executing ONERROR command at macro ./Full_Adder.do line 5

Error.

0 Kudos
3 Replies
RichardTanSY_Intel
904 Views

Hi, 

There is a forum case with similar issue. Let me know if it helps. 

https://community.intel.com/t5/Intel-Quartus-Prime-Software/Univercity-program-VWF-simulation-error/td-p/265537

 

0 Kudos
RichardTanSY_Intel
892 Views

Hi, 

 

We do not receive any response from you to the previous question/reply/answer that I have provided. Please post a response in the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions.

 

Best Regards,

Shyan Yew

0 Kudos
SSchneider
Beginner
885 Views

I was able to fix he error by only deleting the  "-novopt" command from the  "vsim -novopt -c -t 1ps -L ..." line in the simulation configuration.  I originally deleted the whole line which got rid of the first "novopt" error, however, it caused the second generic error.

0 Kudos
Reply