Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26733 Discussions

Cannot configure VS2013 to use Composer XE 2013 SP1 Update 4 after installing Parallel Studio XE 2017 Update 4 Composer Edition

Jerry_W_
Novice
192 Views

I had VS2013 installed and configured to use Fortran Composer XE 2013 SP1 Update 4. Because of the problem with VS2017 15.3.3 not recognizing Parallel Studio XE 2017 Update 4, I planned to install VS2017 15.0 followed by Parallel Studio XE 2017 Update 4 and then upgrade VS2017 15.0 to 15.3 (this is described in another thread in this forum).

I also read that installing Fortran 2017 Update 4 will cause VS2013 to use that version rather than Fortran 2013. This link: https://software.intel.com/en-us/articles/using-older-intel-visual-fortran-versions-in-different-mic... describes how to preserve old compiler versions in older Visual Studio versions. I made a backup copy before installing Fortran 2017 as described in Newer version not yet installed. After installation I used step 3 in this link: https://software.intel.com/en-us/articles/troubleshooting-fortran-integration-issues-with-visual-stu..., to configure VS2013 to use Fortran 2013.

After doing this, VS2013 still shows "Intel(R) Visual Fortran Compiler 17.0.4.210" in Tools | Options | Intel Compilers and Tools | Visual Fortran | Compilers. Interestingly, Help | About Microsoft Visual Studio shows "Intel(R) Visual Fortran Composer XE 2013 SP1 Update 4 Integration for Microsoft Visual Studio* 2013, " I confirmed that Fortran 2017 is being used to compile.

I have tried this a few times, rebooting in between, with the same results.

Does anyone have any suggestions?

0 Kudos
1 Solution
Jerry_W_
Novice
192 Views

Problem resolved.

The article Using multiple Intel Visual Fortran versions in Microsoft Visual Studio (https://software.intel.com/en-us/articles/using-older-intel-visual-fortran-versions-in-different-mic...fails to mention one important thing: when installing Parallel Studio XE 2017 Update 4, there is an option to not integrate with VS2013. To get there, click the Customize button when it appears and then Next a couple of times. Uncheck VS 2013.

Then, after installing Fortran 2017, when you open VS2013 Tools - Options - Intel Composer XE - Visual Fortran - Compilers has Composer XE 2013 SP1 Update 4 in the list. Select this and you are done.

Do this when installing Fortran 2017 and none of the other things described in https://software.intel.com/en-us/articles/using-older-intel-visual-fortran-versions-in-different-mic... and https://software.intel.com/en-us/articles/troubleshooting-fortran-integration-issues-with-visual-stu... needed.

 

 

View solution in original post

7 Replies
Andrew_Smith
New Contributor III
192 Views

I find doing a repair install of the older Fortran versions in reverse oder of vesion after installing the new version fixes it so all work. But have not tried this VS version

Jerry_W_
Novice
192 Views

I did a repair install of Fortran Composer XE 2013 SP1 Update 4 and it did not work.

Jerry_W_
Novice
192 Views

I should have said the repair was successful but did not solve the problem. 

Steve_Lionel
Black Belt Retired Employee
192 Views

Read https://software.intel.com/en-us/articles/using-older-intel-visual-fortran-versions-in-different-microsoft-visual-studio-versions

Jerry_W_
Novice
192 Views

Yes, I referenced this link in my initial post.

Jerry_W_
Novice
193 Views

Problem resolved.

The article Using multiple Intel Visual Fortran versions in Microsoft Visual Studio (https://software.intel.com/en-us/articles/using-older-intel-visual-fortran-versions-in-different-mic...fails to mention one important thing: when installing Parallel Studio XE 2017 Update 4, there is an option to not integrate with VS2013. To get there, click the Customize button when it appears and then Next a couple of times. Uncheck VS 2013.

Then, after installing Fortran 2017, when you open VS2013 Tools - Options - Intel Composer XE - Visual Fortran - Compilers has Composer XE 2013 SP1 Update 4 in the list. Select this and you are done.

Do this when installing Fortran 2017 and none of the other things described in https://software.intel.com/en-us/articles/using-older-intel-visual-fortran-versions-in-different-mic... and https://software.intel.com/en-us/articles/troubleshooting-fortran-integration-issues-with-visual-stu... needed.

 

 

View solution in original post

Jerry_W_
Novice
192 Views

Here are images that show this.

Visual Studio integration selection:

VSIntegration.png

Visual Fortan selection in VS 2013:

CompilerOptions.png

Reply