Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
6 Views

Debugger in XE 2017, problem with latest release

I updated Fortran to: Intel® Parallel Studio XE 2017 Composer Edition for Fortran Windows* Integration for Microsoft Visual Studio* 2013, Version 17.0.0036.12 (Full information below). Last Update before has been in October 2015.

With the new release I encountered a debugging problem. After start of the debugger I am able to view variable values in the WATCH window. Unless I want to view varables defined with TYPE.

Example: If I want to view the variable "BasicMod::channel(k)%iTypA" the complete Visual Studio environment collapses (Message: "Visual Studio does not function anymore") and VS has to be restarted. The content of the Watch window is attached to this blog. Even so the variable to be shown is not an array (it is part of an array, but not an array itself) in the value column a {...} is shown.

Does anyone has a suggestion how to solve this problem?

 

Actual installed release:

Microsoft Visual Studio 2013 Shell (Integrated)
Version 12.0.21005.1 REL
Microsoft .NET Framework
Version 4.6.00081

Installed Version: IDE Standard

Intel® Parallel Studio XE 2017 Composer Edition for Fortran Windows*   Package ID: w_comp_lib_2017.0.109
Intel® Parallel Studio XE 2017 Composer Edition for Fortran Windows* Integration for Microsoft Visual Studio* 2013, Version 17.0.0036.12, Copyright © 2002-2016 Intel Corporation. All rights reserved.
* Other names and brands may be claimed as the property of others.

 

0 Kudos
6 Replies
Highlighted
6 Views

I can reproduce this, but

I can reproduce this, but only if I use the BasicMod:: prefix. You shouldn't need that if the module is used in the current procedure. I will send this on to the developers. It appears to be a Visual Studio integration difference rather than a compiler difference. Issue ID is DPD200415030.

Retired 12/31/2016
0 Kudos
Highlighted
6 Views

Thank you for your help,

Thank you for your help, Steve.

But if I don't use a prefix like "BasicMod::" I get the message "undefined variable channel", as long as the breakpoint, where the debugger stops, is not in the Module BasicMod.

May be I have to change a debug parameter to avoid the use of prefixes? I remeber, that I did not have to use them in earlier versions of the IDE.

Thanks,

Gerd

0 Kudos
Highlighted
6 Views

You should not need BasicMod:

You should not need BasicMod:: if the module and variable is referenced in the routine where the breakpoint is set. There are no options of use here.

Retired 12/31/2016
0 Kudos
Highlighted
6 Views

The module is referenced by a

The module is referenced by a "use Basicmod" statement in the programme where the breakpoint is set. But since  I changed to VS 2013, I have to put the prefix, as long as I am not directly in the module itself. Otherwise I always get the "undefined variable" message.

Gerd

0 Kudos
Highlighted
6 Views

True - if that module is not

True - if that module is not used in the current debugger scope you will need the prefix.

Retired 12/31/2016
0 Kudos
Highlighted
6 Views

I am told that this bug

I am told that this bug should be fixed in Update 2 to Parallel Studio XE 2017.

Retired 12/31/2016
0 Kudos