Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
37 Views

fortran arch file error

Hi, i tried to install parallel studio xe 2016 (file is l_mpi_p_5.1.3.223) for fortran compiler to linux opensuse .  I installed it by install.sh then i sourced it to .bashrc as "source /opt/intel/compilers_and_libraries_2016/linux/bin/compilervars.sh intel64" but ifort doesnt work.

when i try :

/opt/intel/compilers_and_libraries_2016/linux/bin # ./compilervars.sh

the error is :

"compilervars.sh [-arch] <arch> [-platform <platform>]

  <arch> must be one of the following:
      ia32           : Set up for IA-32 target.
      intel64        : Set up for Intel(R)64 target.
  <platform> must be of the following:
      linux          : Set to Linux target.(default)
      android        : Set to Android target.

If the arguments to the sourced script are ignored (consult docs
for your shell) the alternative way to specify target is environment
variables COMPILERVARS_ARCHITECTURE to pass <arch> to the script
and COMPILERVARS_PLATFORM to pass <platform>
./compilervars.sh: line 73: return: can only `return' from a function or sourced script

ERROR: architecture is not defined. Accepted values: ia32, intel64, mic"

what should i do? help me please!

There is no architecture file as intel 64 at " /opt/intel/compilers_and_libraries_2016/linux/bin" folder.

0 Kudos
2 Replies
Highlighted
Employee
37 Views

From my reading of your post, you installed the Intel MPI product only. The cited file you used does not contain the Fortran compiler. The Parallel Studio XE 2016 installation file for Linux is named like: parallel_studio_xe_2016_update4.tgz  (This would be for the latest PSXE 2016 Update 4 release).

You can obtain the Parallel Studio XE downloads from the Intel Registration and Download Center, once installed that would offer use of the Fortran compiler via the setup scripts you tried.

Hope that helps.

 

0 Kudos
Highlighted
Beginner
37 Views

Thank you very much

0 Kudos