Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26729 Discussions

Double-Clicking .FOR file Doesn't Open VS 2017

Nick3
Novice
104 Views

I'm running VS 2017 Enterprise 15.9.3, ifort 2019 Update 1.  On two different machines, when I double-click the .FOR file, I get the prompt about how I'd like to open the file, something about ""/dde.  I believe the registry entry,

[HKEY_CLASSES_ROOT\VisualStudio.FortranFile.15.0\shell\Open\command]
@="\"\" /dde"

is incorrect - it should be

"devenv.exe" /dde

not

"" /dde

(Note the following entry that I believe to be correct)

[HKEY_CLASSES_ROOT\VisualStudio.FortranFile.12.0\shell\Open\command]
@="\"C:\\Program Files (x86)\\Microsoft Visual Studio 12.0\\Common7\\IDE\\devenv.exe\" /dde"
 

0 Kudos
2 Replies
Steve_Lionel
Black Belt Retired Employee
104 Views

I agree with you that the empty path doesn't work, but the replacement you suggest isn't valid for VS2017 since it references VS2013. The exact path will vary depending on what you have installed - for me it's "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\devenv,exe"

Chasing down the registry paths for this stuff is very confusing. Ideally you'd want to select "Microsoft Visual Studio Version Selector" as the app to open, and that works on an individual basis, but even if I check the box to use that app all the time, it reverts back to "" /dde, leading me to believe there's more to this.

 

Nick3
Novice
104 Views

Sorry...Actually, on the machine that has only VS2017 installed, I used the following replacement:

"devenv.exe" /dde

It works as intended!  This might be worth to ask the folks who wrote the installer.

Reply