Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
4 Views

Fresh install of intel parallel studio 2018 : no x64 configuration available for any visual studio 2017 intel fortran project

Hello,

I installed a fresh 2018 intel parallel studio, and regarding Intel Fortran, both Intel Visual Fortran Compiler for IA-32 and for Intel 64 where installed, as well as Visual Studio 2017 integration.

I create a new visual studio solution with a new "Static Library" Intel Visual Fortran project, and it doesn't have a x64 configuration. More generally, I have the same problem with any "Intel Visual Fortran" project I create.

What is happening and why ?

How can I add the configuration myself and be sure that all options for the ifort compiler will be regarding 64 bits ?

0 Kudos
8 Replies
Highlighted
Retired Employee
4 Views

For many years, Visual C++

For many years, Visual C++ did the same thing. I see that it now creates an x64 configuration automatically. Here's how to add your own:

  1. Open your VS solution. Select Build > Configuration Manager
  2. For Active Solution Platform select <New...>
  3. Under Type or Select the New Platform, select x64.
  4. Click OK, then Close.

 

--
Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Beginner
4 Views

Thx. It indeed works but with

Thx. It indeed works but with the following strange and annoying behaviour : if I do it and then I add a second (intel fortran) project, then it also doesn't have the x64 configuration, and if I try to add it from this project properties, the adding doesn't work, with the error "cannot add the configuration because the solution already has the configuration" ... So basically, I can only add the new x64 config one time for all and be sure to never add a new project after. Cannot work like this ...

0 Kudos
Highlighted
Retired Employee
4 Views

If you add a project later,

If you add a project later, instead of clicking on "Active Solution Platform, click on the entry for Platform next to the new project and select <New...>, but this time uncheck the box "Create new solution platform". Be sure to check the Build box before you're done.

--
Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Beginner
4 Views

And what if, as it occured to

And what if, as it occured to me right now under 2018 intel parallel studio update 3 with visual studio integration, I don't have the possibility to choose Under Type or Select the New Platform "x64" as I only have "x86" ? (Config in attachment)

0 Kudos
Highlighted
Retired Employee
4 Views

I'd rather see the screenshot

I'd rather see the screenshot of the New Platform dialog.

--
Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Beginner
4 Views

Here you go.

Actually, if I do a Build --> Configuration Manager then I click on the "x86" from the "Active solution platform" in front of the "Active solution configuration", then "New" then in the "New Solution Platform" window I can select x64 but I don't know what to choose in the "Copy settings from". For sure I won't choose "x86" as I guess the settings won't be the same for x64 and x86, or ?

0 Kudos
Highlighted
Retired Employee
4 Views

Yes, Select New, then x64,

Yes, Select New, then x64, and let it copy from x86. That's the way to do it. The only thing that really matters is the configuration, which selects the compiler. If you have explicit paths to external libraries you may need to update those in the new configuration.

--
Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Beginner
4 Views

Ah ok, wasn't sure if

Ah ok, I wasn't sure if something else than the compiler + path was important, so thank you very much for comfirming it, Steve !

0 Kudos