Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
160 Views

Inability to load "incompatible" files following Visual Studio 19 update

Jump to solution

Microsoft sent out an update to VS19 Community this am (HST).  Before that, my VS19/PSXE2020u4 system was working fine.  After updating, I attempted to restart VS and continue my work, but got message "There was a problem opening 'FSSRM.for'.  Please load the 'COGNIT (incompatible)' project and try again."  I got a variant of the same message for COGNIT.for.  Those were the only two files open in the VS19.  There was some other stuff, which I can provide if needed, including Error Code: 0x0000139F.

In addition to attempting to reload my project, I also tried all possible combinations of reinstalling PSXE2020u4; no joy.  Would appreciate having a way to avoid completely rebuilding this project (for the second time ...)

Mahalo, Mike

 

0 Kudos

Accepted Solutions
Highlighted
Black Belt Retired Employee
153 Views
  • Open a Windows Explorer (file) window to view the solution folder.
  • Click View, then Options.
  • Click View
  • If not already selected, click "Hidden files and folders > Show hidden files, folders and drives
  • Click OK
  • If you now see a folder named .vs, delete it.

Now try VS again.

 

View solution in original post

0 Kudos
2 Replies
Highlighted
Black Belt Retired Employee
154 Views
  • Open a Windows Explorer (file) window to view the solution folder.
  • Click View, then Options.
  • Click View
  • If not already selected, click "Hidden files and folders > Show hidden files, folders and drives
  • Click OK
  • If you now see a folder named .vs, delete it.

Now try VS again.

 

View solution in original post

0 Kudos
Highlighted
New Contributor I
82 Views

Thanks, Doc.  Your solution got me part way to where I needed to be.  However, it also revealed a shortcoming in how my project files were set up, so I ended up doing a complete rebuild anyway.  I think it's a worthwhile investment in the future.

Thanks again for your help.

Aloha, Mike