Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
27558 Discussions

Integration with VS2022 shows all Fortran projects as "incompatible"

AONym
New Contributor II
765 Views

I installed Intel® Fortran Compiler – toolkit version: 2022.1.0 and specified only VS2019 integration. The installer did not show any errors. I was able to create a new Fortran project, compile and run it.  So far, so good.

I also have VS2022 17.0.5 installed. I wanted to try VS2022 integration, so I ran the Fortran installer again, specified Modify, and checked 'integrate with VS2022' only. The installer ran without showing any errors.

But when I start VS2022 and open a Fortran solution, VS shows the projects as "incompatible", and Help/About does not show any Fortran under installed products. So apparently the installer did not do the integration with VS2022.

How can I get the installer to complete the integration? And why doesn't it alert users that integration failed?

0 Kudos
1 Solution
AONym
New Contributor II
632 Views

Devorah -

Following your instructions, I

1) Uninstalled Fortran compiler 2022.0.0.

2) Updated Base Toolkit v.2021.4 to v. 2022 selecting VS integration for VS2019 and VS 2022.

3) Updated HPC Toolkit v.2021.4 to v. 2022 selecting VS integration for VS2019 and VS 2022.

After this, VS2022 showed Intel oneAPI products were installed. Fortran projects, however, still showed as "incompatible".

Right-clicking on each Fortran project and selecting "Reload Project" changed "Incompatible" to "IFORT", and now everything seems to work normally.

I've attached the logs, including those from previous install attempts.

View solution in original post

13 Replies
Devorah_H_Intel
Moderator
751 Views

Try reinstalling HPC 2022.1 again with VS2022 integration. Attach logs from that reinstall if the compiler still missing from Help/About.

VS2022 integration is still limited but we would like to see logs from failed integration if possible. 

AONym
New Contributor II
733 Views

I have attached the log file from `...AppData\Local\Intel\oneapi\Samples\Logs`. I installed Fortran 2022.1.0 yesterday, with only VS2019 integration, and tried to add the VS2022 integration today.

I have not yet tried uninstalling the compiler, then reinstalling it.

AONym
New Contributor II
667 Views

Devorah, can you give me instructions on how to do the reinstallation of HPC 2022, and where to find the logs?

AONym
New Contributor II
633 Views

Devorah -

Following your instructions, I

1) Uninstalled Fortran compiler 2022.0.0.

2) Updated Base Toolkit v.2021.4 to v. 2022 selecting VS integration for VS2019 and VS 2022.

3) Updated HPC Toolkit v.2021.4 to v. 2022 selecting VS integration for VS2019 and VS 2022.

After this, VS2022 showed Intel oneAPI products were installed. Fortran projects, however, still showed as "incompatible".

Right-clicking on each Fortran project and selecting "Reload Project" changed "Incompatible" to "IFORT", and now everything seems to work normally.

I've attached the logs, including those from previous install attempts.

JohnNichols
Valued Contributor II
749 Views

As no one has replied, and with the caveat that I look after machines mainly running WIndows 11 - a lot of versions, and one Windows 10 machine, I dislike having to play with it, it lacks the nice new wizards of Windows 11.  I shall provoke a negative response here, if you are new to this forum, ignore it, it is merely part of a long running banter, between experts and non - experts. 

The nuclear option is often the fastest in frustration terms:

remove all Intel Fortran's back to the year 123 BC when Intel was first thought of by the Romans.   Cicero in a speech to the senate, said, 

Video turbam ortam in horizonte

remove all Visual Studios.

Do a disk clean, I would also use ccleaner, but Steve will tell you not, 

Install VS 2019 and if you like 2022, the oneapi installers objects if vs 2019 is missing -- I know not why and I will be told in the next hour this is wrong, but alas it is not. 

 Only install the latest oneapi, you do not need anything else.  

Finally if you do use mkl 32 bit wander over to the mkl forum and pick up @mecej4  link to the 32 mkl, there may be one on this thread, but as Bunter failed to deliver a pot of tea in bed this morning, I am not fully awake.  

 

 

Devorah_H_Intel
Moderator
739 Views

I did reply before you. 

I disagree with some of your suggestions. I do agree about using the latest oneAPI if possible. 

JohnNichols
Valued Contributor II
719 Views

Yes, but it takes several minutes to type a response and the web site does not update the page as you type, so I had no way of knowing you had replied.  

The beauty of life is the ability to disagree.  I merely talk from maintaining quite a few computers all with VS and IFX, you can spend a lot of time trying to fix an installation, or you can take the route of just redoing it from scratch, which given the current speed of installataion of VS and IFX is really the fastest method.  Having multiple copies of IFX is really a conflict waiting to happen.  

Diskclean is a good idea to clean up the 20 GB of old windows files on an update.  CCleaner has not caused me any problems in many years of use, it cleans out caches etc.. .  

One should also clean out the old dmp files from SQl Server that in a month can occupy 200 GB of space and do not automatically delete, even when you set the correct switches.  

 

 

JohnNichols
Valued Contributor II
717 Views

VS2022 integration is still limited but we would like to see logs from failed integration if possible. 

I also agree on this point  - on all of my computers including Windows 10 I still get the error cannot load the Fortran files to the editor on opening.  This is a lot of computers, all with different configurations. 

 

The integration causes fewer problems on Windows 11 than on 10. 

Steve_Lionel
Black Belt Retired Employee
712 Views

I have not seen integration failures with VS2022 on either Windows 10 or Windows 11, but on both I routinely get this when opening an existing solution when it wants to open a source file that was open when I last closed the project.

Screenshot 2022-01-26 190402.png

Double-clicking on the file in Solution Explorer opens the file successfully.

JohnNichols
Valued Contributor II
703 Views

I had reported this error a few weeks ago, showing the same screen.

I tried to install one api on vs 2022 alone, it threw an error at the start of IFX install, saying not possible without vs 2017 or 2019, it was a weird format not your normal Intel Format, it would not proceed.

and with the latest oneapi, one computer would not install until all of the old versions were removed. 

Install is so fast it is simpler to remove all and just do a clean install.  

 

One a NUC I had just pulled from a bridge, I had updated the graphics driver from Intel and then IFX install said no graphics drivers.  

Devorah_H_Intel
Moderator
656 Views

@AONym 

To uninstall - open Add or Remove programs from Start menu. Select oneAPI Toolkit you wish to uninstall and click Uninstall.

After completing the uninstallation process. Click on the installer of the oneAPI package you have downloaded - run the installation process. In the end, there will be a message where to find logs of the completed installation. Normally in this directory C:\Program Files (x86)\Intel\oneAPI\logs 

 

 

GedLee
Beginner
540 Views

I am having this exact same problem.  I tried the proposed solution but it didn't work.  I got no errors on the FORTRAN install. but no FORTRAN anywhere in VS2022.

AONym
New Contributor II
461 Views

@GedLee: First, you should check that Fortran was integrated w/VS2022. In VS, menu Help, click About Visual Studio. You should see the oneAPI packages in the list, in particular Intel Fortran Compiler. If you don't see this, you may not have checked "Integrate with Visual Studio" during the Fortran installation. If you do see this, then open a solution containing Fortran project(s), locate one in Solution Explorer. Then right-click and select "Reload Project"; this should change "Incompatible" to "IFORT" if you're using Fortran Classic.

Reply